Got a Zero Delay PCB to put in my old PS3 SF4 Fightstick TE (to use it with the PC), but it's not re


#1

Maybe someone here can help - I’ve connected the zero delay pcb up to the stick and buttons, but it isn’t showing up in windows (besides the usb device connected jingle). Pretty new to this stuff - I tried disconnecting everything so that it was literally just the PCB attached to the PC via USB, but no difference (it should show up as a joystick even if no buttons are connected, right?).

If anyone here has any ideas on what to do, would love to hear it! Equally if it’s just a duff board that’d be good to know too so I stop trying to get it to work.


#2

We need photos of how the USB is connected to the ZD PCB.


#3

Can’t get a photo right now but I mean, the USB just goes straight from the USB port of the PC into the USB 4-pin top-left of the card. Am I missing something huge here?


#4

Could the USB connection to the PCB be inserted backwards?


#5

99% sure it is as the pin-connector is grooved in one side to slot into place - also (and I should’ve mentioned this in the OP) - the red power LED does come on. Not the green mode LED, though.


#6

Got a multiumeter?


#7

Yeah I’ve got one, any pins in particular I should check? Pretty new to this stuff, built a few PCs (got the multimeter to check a dead PSU once) but that’s about as far as my knowledge goes! Appreciate the suggestions


#8

I’ve always wanted to know: How much “zero delay” is in the Zero Delay compared to other PCBs (Ex. Ipac)?


#9

Just look up USB pin outs or use this link
http://pinouts.ru/Slots/usb_pinout.shtml

I would just check each and every pin as anyone of these broken could effect your stick.


#10

So all 3 pins give the same resistance reading when paired with earth(4), which I would guess is a good sign? Testing pins 1 and 4 turns the power LED on, which is no surprise as the pcb definitely receives power fine. Is it possible the PCB is fine and this is just a windows thing?

Also just to confirm, the PCB is completely self-contained and doesn’t need to be connected to anything else in the fightstick to at least show up in Windows, right? I’ve stripped everything off for testing so that it’s just the ZD PCB with just the usb pins connected to my PC. It doesn’t need to be fully wired up to the buttons/stick to at least show up in Windows I’ve assumed, but maybe not?


#11

This is what I would try. I’m not sure which version of windows you are running but normally if windows detects the power, ground, Data + and Data - from a USB device it should prompt “device is not recognized” if it doesn’t have a clue of what has connected to it. In addition, I would start up the PS3 and connect the ZD PCB to it when the dashboard is finish loading. The PS3 will prompt on the top right side of the screen if the device is not recognized. If you don’t see that prompt, take a single wire and touch one end to a ground point of the PCB and let the other end touch a signal point like left or right. If it moves then PCB it works but not with PC. If nothing happens then your USB cable is not connecting those 4 wires correctly and the PS3 or PC doesn’t realize you are connecting anything. You got me? Your only hope is to find another USB cable and attempt to solder the 4 wires (Power, ground, D+ and D-) or at least hold them down with electric tape to test the theory. Good luck.


#12

You don’t need to check the resistance of the other wires to ground, you are looking for continuity of each wire, seeing if there is a break. One at the Plug end and the other where the cable attaches to the PCB


#13

I think some ZD PCDs need to have the mode button connected in order to work properly. If it’s not, try connecting it to home or a spare button or something.


#14

Unless the button is constantly pressed, I don’t see how that would work. Just having the button there and wired up does not do anything, there no current being sent though the button until it’s pressed.


#15

The mode button is the ps3 home button, correct? Because it’s only a 2-pin connector on the PCB, but seems to be a 6-pin out coming from the home panel, presumably because of turbo etc. So I’d need to do some wire cutting to connect it - tried shorting the pins while it was turned on but nothing happened.

Thanks - I tested the continuity of each wire and all seemed to give readings, although not consistently (though this may have just been the probe not making good contact on the usb plug end).


#16

Also as a long overdue sanity check, here’s both sides of the pcb:

http://i.imgur.com/9HrLcxt.jpg

Attaching the usb to the 4-pin connector in the top left, have taken everything else out for testing purposes (after initially trying with all buttons/stick connected).

http://i.imgur.com/lp6ZHeX.jpg


#17

Any luck with this so far?


#18

Nope am all out of ideas :frowning:
Doesn’t seem to be a problem with the USB cable, nor the pins. Windows makes the USB-connected jingle but nothing shows up in the gamepad/joystick screen.