Grrr! GGPO AND 2DF not working!


#1

I’m trying to play some online SF. I’ve had a bit of success with MAME32 0.117, but the experience was a bit slow and laggy so I decided to try GGPO. Created an account, installed Adobe Air but when I tried to log on nothing happens at all. This has happened twice, once when I tried before I reformatted my hard drive and once after I reformatted, same problem both times.

So then I try 2DF Freeplay. Install everything, and after a few minutes it just comes up with an error saying the operation request timed out when trying to contact the server (or something to that affect). So frustrating! Are there any solutions to either of these problems?


#2

Router/Firewall/Ports.


#3

Open UDP ports 6000-6009 (inbound/outbound) and TCP port 7000 (outbound) in your home network. GGPO uses these ports to communicate with the matchmaking server and with other players on the internet. (taken from ggpo.net)

Took me a couple of hours to figure out how to do it.

http://portforward.com/routers.htm


#4

good posts :tup:

edit

also…

I miss father brain <3

also im a little tippsy

also i bout a mic again big brain.


#5

hahaha, dude nice avatar, i thought i was the only one that SPD his wife, and sometimes i SPD my kid too. :wink::rofl:


#6

why cant my HRAP 3 work on 2df?? please help!!, lol Im trying to play 3s


#7

Check if you need to get drivers to play on the computer with it. I thought it was just plug and play.


#8

I had the same problem.

What you do is go to the control mapping, then double click on what you want to change, and then use your stick to program it.

Example:
F5, double click up, up on joystick.
F5, double click weak punch, push square.


#9

lately 2DF just refuses to even start up. I have had an account there like forever, I have .NET 3.5 installed and when I choose runclickonce it never starts up. I don’t even get a window open or anything. the computer just sort of ignores me.


#10

Wouldn’t it be easier to just get port magic to forward the ports?


#11

Aight bet, I’ll try once I get home…So, I have to select “joystick”? Does it matter if I select “jostick 0”?, etc…

Hope this works, Ive never played 3s before…


#12

im just going to say this now, i hate GGPO, i connects 1/4 of the time, then you have to exit and come back in multiple times after that

i mean shit, how long has it been out and its still in BETA phase??
wtf, something not right

a beta that lasts over a year?


#13

Dudes, calm down. That’s the problem with online programs, is that they are buggy and crash every now and again. So bear with them and just report the problems in a non bitchy way. Bitching on SRK solves nothing.

go to ggpo.net and report the problems to their section that is dedicated to Problems and Troubleshooting. Also, they have an IRC channel on efnet.org. #ggpo is the room name. There you can address your problems and someone will be more than happy to help you.


#14

I just did the very first option of them. I could be wrong, but I think it’s Player 1 -> Joystick 0 -> Absolute. After that you just map everything how I explained it.

Hope this helps.


#15

Actually it doesn’t matter, because certain sticks are going to map different. For instance, I have a hori EX2 and my buttons would map differently than, say, an HRAP. Also, if you have more than one thing hooked up into your USB ports (A spare pad, for instance) the Emulator will classify that as “Joystick 1” to differentiate the separate sticks/pads. So that way it doesn’t accidentally map two sticks onto one set of buttons, which would lead to some problems in the game…obviously.


#16

Thanks eric, I got it to work last night…no to practice some combos with Ken & Ryu!! I never knew how much I sucked…havent played since SNES & Genesis