Guide button for my 360 TE stopped working


#1

It stopped working after I connected my stick to my laptop to play a game. It still lights up and stuff but when I press it nothing happens at all. Did plugging it in to my laptop mess something up?


#2

Does it work on a 360?


#3

@TC: Ok, forgive the facepalm’edness of this thought, but is the lock on?
(sometimes it’s the simplest of things)

@gahrling: Does the guide button work on computers? It doesn’t reg as anything when i’ve tried. Just lights up w/ the power… but that’s it.


#4

Yes - the Guide button does work on PC’s. Because the button isn’t immediately recognised in the joystick diagnostics program, the easiest way to test it is using a Windows Live game like street fighter four.


#5

Yes, I’ve made sure the lock was off. When I connect it to my 360 the rest of the stick works fine, the buttons and the actual stick. Its just the guide button that I guess does not register when I push the button. Even with my 360 off I tried using the guide button to turn it on and I got nothing.


#6

shrugs Without using a multimeter or having a look at your arcade stick it will be difficult to diagnose the problem. Could be a loose ribbon cable wire, a damaged or badly aligned rubber pad under the Guide button, or the PCB could be compromised.

If it’s still in warranty and you’re uncomfortable about opening it up, then contact the store you got it from or MadCatz for advice.


#7

I’m pretty sure the Warranty is up. I got it back in 09. Though I have no qualms about opening it up so I’ll open it and see what I can find. What kind of screwdriver do I need to open it?


#8

Use a hex key to open up the top bolts. You shouldn’t need to touch the screws on the base plate.