Having an issue with TE2+ losing connection on PS4


#1

My TE2+ will seemingly randomly lose connection on my PS4 and become unresponsive. However, the light bar and lock buttons etc. will remain lit up. I have to unplug and replug it in. Only upon unplugging it will the PS4 say the controller has been disconnected. This happens across multiple games, and in both usb ports, and even happened with a friend’s TE2+ on the same console. I’ve also tried a powered usb hub as reddit suggested with no luck. Any ideas what could be causing this?


#2

Are these stock TE2s or do they have the brook board in them?


#3

It’s a stock TE2+ I haven’t made any modifications to it. I bought it July 2016 and haven’t had any trouble until about a month ago. My PS4 is a launch model so it’s probably from November/December 2013


#4

Maybe a defective USB cable


#5

Try using another power source for your PS4… if it’s connected to a powerstrip try using another one… some ps4’s are very sensitive with this kind of sh*t.

Even in tournaments some ps4’s disconnect usb devices randomly. it sucks a lot


#6

I’ll give it a shot


#7

Also Try to pick up a powered USB Hub, one with it’s own AC wall adapter.


#8

I already tried that and it didn’t help


#9

Update: the TE2 now disconnects repeatedly on my PC as well. It also failed on a second PS4.

So what do I do? Buy a refurbished replacement cable? Or could the problem be with the board?


#10

got access to a multimeter? Test out the cable for any breaks/shorts.
You want to see if the USB cable failed or not USB cables are a easy fix, just 4 wires, 5 if you include the shield/drain wire (which gets tied to ground).

There is a thread how to make your own TE 2 USB cable


#11

Just tested it with that guide. Looks like there’s a break in the cable near the 5 pin end. Ordered some new ones off Amazon and praying.