Help! CPS3 audio problem


#1

Hi, I have a CPS3 3rd Strike (CD version), and I’m having an audio problem. Hopefully somebody here has some insight:

In Jamma mode I get mono audio that plays properly.

In External mode I hookup left/right RCA cables and the audio is properly in stereo, at first. After like two minutes, the left channel fuzzes out and you can hear just a little static get through. Then a bit later, the right channel turns into a mono channel or intermittently comes and goes entirely.

Also I have to put the volume on MAX to get enough of a signal to even amp it decently with a 2.1 speaker setup.

So, any ideas? Is some chip on the board dying? I lack the ability to diagnose exactly what’s gone wrong. When I plug in other CPS2 or CPS3 boards the audio functions properly.

Or is there a way to get stereo out of the Jamma connection? The Jamma audio works fine, it’s just in mono though.

Thanks!


#2

I’d rule out your audio cables first. Just my opinion. :wink: Try hooking some headphones up with an RCA to 1/8" mini plug stereo/stereo adapter. See if you still have the problem there.

If so, no there (generally speaking) is not 2-channel audio on the jamma harness. Next step would be to trace back on the board, and try tapping audio from the line someplace back. You may just have a cracked trace that gets screwy once the board gets warm. Re-flowing some of the solder joints leading up to the RCA connection can sometimes help this too.

If those don’t help, I have to back off to some of the people better with PCB’s around here. That’s the extent of my surface-mount troubleshooting ability.


#3

Thanks, I’ve tried other PCBs and they sound fine.

I’ll probably hold out for more specific instructions before I go on a mad soldering expedition. Given that it happens after running awhile, it probably is something like that. Hmmm… makes me consider running a fan on it.

Even when it’s just turned on though, the left RCA output is a bit weaker than the right.


#4

Sound like the on board stereo amp’s dying. I’m not sure what chip or chip set that is. =/ But the good news is that atleast your cart’s not dead.


#5

Yeah, not dead but I want to hear the game in nice stereo sound! I have another 3rd strike but its the one without all the sounds (no hadoukens or pre/post game character sound bites).

Is this the best place to hunt for this info? Most of my net searches turn up “CPS3 cracked!” and “suicide battery replacement”.


#6

I’d also check Neo-Geo.com.

A few guys there are sharp on the CPS-3 system.

Follow the traces on the motherboard and check out what chip it’s connected to, as well.


#7

You’re not giving any information on what kind of environment you’re running the game in like cabinet or supergun details. Have you tried running the other CPS3 board, in stereo, in the same environment as the one exhibiting the problem?


#8

jamma is mono only. you need an amp for stereo


#9

Here’s the machine it’s running in:
http://avatar.telefragged.com/newmachine.jpg

When I run CPS2 games it works fine in that environment. I don’t know if other CPS3 games have the same issue in this cabinet, I have CPS2 games laying around but my only other CPS3 is in a machine. You think the machine may effect CPS3 games but not CPS2? I guess I could try the other CPS3 PCB in there.

The guy I bought the PCB from suggests applying WD40 to the volume knob.


#10

I’ve been using a subwoofer with speaker outs for the sound, one of those Creative Labs speaker sets.


#11

I was thinking it could be a PSU voltage issue but then discarded the idea, would’ve been more likely if it was the other way around (more power being drawn when the on-board amplifier is active). Probably some kind of heat issue with the motherboard as already suggested by Numbski… What happens if (after the sound goes wrong) you power down and up the cabinet, is the sound still weird or does this reset the “timer” and it takes a few minutes again until it starts sounding strange?


#12

IIRC it stays weird unless I power down for awhile or change the audio cable.


#13

If I keep the Jamma sound plugged and plug the stereo RCA outputs into my 2.1 system then the audio appears to stay normal (going on 15 minutes anyway, I’ll check in a bit to see if its still working properly).

Originally I would connecting the cabinet’s speakers to my subwoofer, which meant that port 10 on the PCB’s jamma connector was going no where. Am I meant to terminate it in a certain way? Might this have contributed/caused the problem somehow?

The current setup, with the 2.1 system and the machines speakers going at the same time, is not a real solution, because the machine’s speakers are still in mono and I don’t really want to have the crappy speakers from the 2.1 system in the equation at all.