Help HRAP mashing/turboing select button


#1

For some reason my HRAP has started to mash select. I don’t remember it doing this in ps2 games but I don’t have one here atm so I can’t test it. I did have some trouble with it on ps2/ in general with it going out completely and thought the cord was busted but I stretched out the cord and haven’t had that problem since (its not even frayed yet).

Tried messing with all the turbo buttons and taking the QDC’s off the select button but its still mashing it. Also tried unplugging the cord a few times. I’ve only seen it happen so far on pc/ps3 so I’m not sure if its my inpin adapter. Theres like no sessions by me at school anymore so i cant test it on anyone elses stick/ dont have a ps2 pad here to test it on.

Anyone know what the problem might be and have a temp/perm fix? I noticed the select button is linked with a black wire on the stick and theres a black wire in the plug. I have no idea how to disconnect it from the plastic piece without ruining it though and some of the buttons don’t have matching color wires on the cord so I don’t know if DCing it will DC other buttons too. :wasted: