HELP! Modded stick. Strange button problem!


#1

Ok i’m hoping there are more than enough techies here to help me out with this odd and frustrating problem. I just modded my Hori FS3 with sanwa parts. Everything went well. I’m not new to soldering. I took everything carefully. Was careful not to create any bridged connections, or scratch the pcb, etc. Also the bottom plate is covered in electricians tape so there are no problems grounding out.

Here’s my problem. The PCB registers L1 as being pressed and held down ALL THE TIME. :annoy: To be clear, there actually is no L1 button in the unit. I had a button in there and thought the problem was physically the button itself, so i removed it. Still had the problem. Then i desoldered both wires for L1 and cleared off the solder. Still have the problem. Right now I have a completely un-soldered L1 on my pcb and its the only thing giving me any troubles. The L2 button was also soldered and desoldered at the same time as the L1 and it has never had problems despite being put through the exact same process. I just cant get the thing to stop registering that L1 is being pressed. Actually… sometimes it sponatenously stops registering it (as if its being released) but invariably goes back to permanently ON (pressed and held).

Now i’m open to any and all solutions, including permanently breaking off any connection to the L1 button, as I have no use for the L1/L2 buttons at all.

Please don’t respond with “disable L1/L2 in the options menu.” The reason why this doesn’t work is L1 is still being registered by the ps3 as if its being pressed, and… guess what, if you’re holding L1, you can’t directly work with the XMB while in a game. Also you have problems establishing a network connection… and you can’t send messages. Great “feature” huh?

Any theories and solutions would be a huge help.

PS> I mentioned i looked thoroughly for bridged connections and couldn’t find any. However, I did use flux on my solder and some of it got on the board around the rings i soldered. Is it possible the flux residue is causing a bridged connection? If so that’ strange because the other connections aren’t exhibiting the problem, and i also tried to clean some of it off to no avail.

Steve

Picture added:

Pic of PCB

http://www.platinumaudiolab.com/uploads/HORI_BOARD.jpg


#2

I don’t think flux is electrically conductive, at least not rosin core flux.
If I were you, I’d check what you were seeing electrically at the pad with a multimeter. The easiest way to rule out a bridged connection is to see what your resistance is between signal and ground… unless this is some sort of analog button (I haven’t modded any PS3 controllers). If the signal point isn’t shorted to the ground, then the only thing I could think of is the chip itself has some issue where it thinks it is shorted (bad controller). However, maybe someone else can think of another solution, so don’t give up yet…


#3

Do have voltmeter? Test the ohms for each place that solder is connected to the pcb. It could be your ground. Re-check all your connections to make sure you are not shorting out. Do you have a picture of the pcb for review? I don’t think flux could be your problem. Hope that helps.


#4

Picture added to original post. I don’t have a voltimeter. I may have to buy one. As you can see in the picture, this is a HORI PCB, not a pad-hacked pcb.


#5

You might have burned out the r21 & Sw8 in the pic. The pcb needs to be cleaned up a little with some 90% -99 %Rubbing Isopropyl Alcohol. When you soldered the buttons, do you leave the iron on for long time? You could have cold joints also. Desolding wick is better then a Soldering pump. Flux helps with some hard solder that is stubbard to remove. Did you use flux on the whole pcb?


#6

From the pic, the board has a lot of solder bits (too many imo) probably from soldering/desoldering. I think some of them may be causing the L1 button to short circuit since I had something similar happen to me in the past. You could try using a brush to clean the PCB if u got one.
Check in between the pins of the IC too.


#7

Can you post a pic of the reverse side of the PCB?


#8

im going to have to guess it has something to do with the traces being slightly messed up…


#9

2nd for a pic of the other side. you never know.

does that button share a ground with anything else? i know little of that particular board. if it does, and it’s somewhere else, the signal might be getting connected to it at the other ground.

a multi-meter is your best friend.


#10

Some new information: i’ve noticed a pattern with the unit. It appears that when I first power it on, I don’t have any problems at all for about 5-10 minutes. But then spontaneously it goes into the L1-always-pressed problem. The only thing i can think of is that something is heating up and causing a bridge somewhere? By a small fraction? I’m far from expert, so are there any other theories…?

I can’t really take a picture of the underside of the PCB because that would require unsoldering all of the connections. I have looked at it carefully though with the buttons out and it looks completely fine. There are no loose connections or debris or anything. And I only used flux on the wires i soldered to the board.

The SW8 looks messed up because i did leave the iron on a bit too long only when removing those wires. However, that was AFTER I had any of these problems with the L1 button, so it hasn’t changed anything.

I tried cleaning the board with a q-tip although i will have to get my hands on some stronger alcohol. I have 50% and i’m afraid that probably isn’t a good enough concentration. The board probably looks a bit worse than it is in that picture. There really aren’t that many bits of solder on it. Still, I will clean it when i’m sure of what i’m doing.

I don’t know how to find out what is ground and what isn’t.


#11

you’ll need to follow the trace that L1 connects to. should be 2 sides, a signal and a ground. see where they go.

if you had a meter, you could check resistance between several points. this would show you if you had a bridged connection. an open switch has INFINITE resistance whereas a closed one has a very small amount.


#12

If you used 50% Iso rubbing alcohol for cleaning pcb, the rest is water which leads to shorts on the pcb. The best is 99% Iso rubbing Alcohol or Vcr/Dvd Cleaner from Radio shack, which 99% Alcohol. Use a old toothbrush and scrub litely on the pcb and use comprerssed air to clear the rest off the pcb.

If you left the iron on too long on SW8 it burnt out the joint, look for a spot near the pcb trace and scrap with a small flat head screw driver or Xacto knife.

The ground is connected to all buttons and just follow the ground from its trace.
Hope that helps.


#13

Well. I cleaned the board about a week ago with 50% isoprophyl and dried it well. It didn’t seem to change anything. Then I noticed a day later it took almost an hour of play for the controller to get the problem of L1 being held down. Then after that I’ve played about 12 hours over the course of the week and haven’t had the problem come back. BIZARRE! I really didn’t do much other than take the cover off a few times. I did notice that the R2 button (bottom left of the picture) has a loose trace (partly lifted) but seems to be soldered firmly to the wire nonetheless. Maybe that was somehow causing problems all this time and simply need to be knocked into place… or something. I don’t know but i’m glad it seems to be fine atleast for now. Thanks for all of your help.