Help! Padhacked a wired X360 controller but I has a missing capacitor!


#1

I recently attempted to build my first arcade stick by padhacking a wired Xbox360 controller for use on my PC. Whilst taking apart my controller, I had noticed a missing SMD capacitor near the microprocessor. I’ve circled it on this pic.

I honestly don’t know how it disappeared and I couldn’t spot it anywhere on my workspace. This capacitor looked like it was critical for the controller’s operation as it was pretty much connected in series to a pin of the microprocessor so I knew I was in one heck of a pickle.

I tried to deduce what the value of the capacitor was based upon the size and what kind of capacitors were placed around it. It looked like a ceramic SMD capacitor so I googled/wiki’d some info out and deduced that they could be C0G/NP0 or X7R ones. I don’t exactly know capacitor specifics, but I read that the largest C0G/NP0 capacitors reach 0.1uf so I placed a 0.1uf greencap on it.

I didn’t expect this drastic measure to work any wonders, but it somehow works, but only occasionally (like a 5% chance to successfully connect to my PC). I had some serious doubts to whether it would run reliably so I went and asked around for help. I’ve had no luck at the Xbox-scene forums, so I hope someone here on Shoryuken could help.

I’ve yet to test other values but I’m not sure whether I should go larger or smaller. I also risk damaging the board or the chip doing so. I’ve tried to trace where the capacitor goes to in hope of trying to identify what the microprocessor uses that pin for, but the tracks are way too fine and the board is double sided, which adds to the confusion.

Generally the first time I plug it in after a certain time, it works. This may be because the capacitor has been discharged or something. Initially, LED’s 1 and 4 light up before the rest do, and then they stop. I’m not sure what this indicates but I’m just adding any detail I can.

In all honesty, I don’t know for sure that the problem is with that capacitor though. But it seems like the most obvious problem so far. The only possible problem I can find would be within the resistors I’ve installed on the analogue sticks. Whenever I had got the pad to work, I’d have a look at the joystick manager on Windows. The analog stick variable capacitors have been replaced with 5.6k resistors which should work fine. But the sticks appear engaged (bottom right), whereas the triggers and buttons seem fine. I havn’t exactly investigated it too much since the missing capacitor seems like a larger problem.

I’ve also got another capacitor missing. The picture is here.
I don’t think it’s a particularly big issue since it’s connected from the vibration motors to the ground, but I guess I’m just shoving in random details here.

That’s probably all the problems that I can identify so far. I’m quite convinced it’s that missing capacitor near the microprocessor was critical for the board’s operation. If anyone has any advice or even a solution I’d appreciate it.