Help! Problem with Quanba q2 on Ultra for Steam PC


#1

hey guys, first time poster here with a question that has been pissing me off for awhile now…

i have my quanba q2 glow fight stick plugged straight into a usb port on my PC.

I boot up the game and go to arcade mode and for some reason it doesn’t work, but when i press start it says “new challenger blah blah fucking blah” and treats the controller like its player 2 (WTF?!?!?!?)

I’m at my whit’s end on how to fix this, I’ve tried searching for answers on google and found nothing, so this is my last resort…figured if anyone knows how to fix this problem it would be on this forum…

thank you guys for your time and I would greatly appreciate any help at all! <3


#2

For some reason, the computer thinks that you’re on keyboard for player 1 and is counting the Qanba as player 2.


#3

Does this happens in all games? When you get to main menu , try pressing start on your stick and don’t press anything on your keyboard


#4

So since you’re a first time poster I’m guessing you might be a first time PC stick user? Did you set the options to the stick first?

I’m not in game right now but with your keyboard…go to options > controller > hit right a few times until it shows the Qanba stick. After that you should be good to go.


#5

Yeah I don’t even touch my keyboard when I boot the game, I just use my stick as soon as it launches. Do you think I need to unplug my keyboard every time I want to play?

It only happens in SF4, not in any other game.

Thank you so much for your guys` help, I’m going to try this when I get home today, hopefully I don’t have to keep disconnecting my keyboard everytime I want to play >.<


#6

UPDATE: okay so I tried everything, including completely unplugging my keyboard and only using the fight stick and STILL it does this fucking bullshit…sigh I’m so fed up, wasted a shitload of money, can’t play single player, can’t train single player, only thing I CAN DO is play online and get the living shit beat out of me by pro players…awesome…guess I’ll just have to wait till one day when this game finally comes out on xbox one (if that ever happens, in which case ill have to use a pad again, hate my life).


#7

with that said, would anyone want to buy my stick? its useless to me now. its a really nice quanba q2 glow (xbox 360/pc). i live in los angeles.


#8

Being that it’s a 360/PC stick, do you have the Xbox controller driver for PC installed?


#9

Is your pad plugged in? And when you say when you press start, do you mean actually press start or start arcade mode? Try also going to controller settings. you can set your stick as player 1 in the settings.


#10

don’t mean to highjack a thread with my own problem but I didn’t think another thread was necessary. Is there a way to test a fight stick to make sure that it will work before I buy Ultra? I have a playstation 3 arcade fightstick, the smaller white one. When I plug it in it detects it as a PC wired USB stick which is a good sign I just want to know for sure before I spend the money to buy it. Can anyone help me out?


#11

PS3 sticks detect as DirectInput, so all your buttons will be labeled “Button 1, Button 2” etc. It’s a bit of a pain in the ass to navigate the menu and remap them properly, but once that’s done they’re good to go. You also have the option of using MotioninJoy/BetterDS3 to pipe it through Xinput and make Ultra think it’s a 360 controller (thereby showing all those buttons in the UI instead).

In short, you should be fine. Only old NVIDIA-based chipsets had issues with PS3/PC sticks, and those instances are fairly rare these days.


#12

yes I do


#13

No pad is not plugged in. I mean press start after I select my character in arcade mode. I tried going into controller settings but it doesn’t give me an option to set anything to player 1.


#14

Delshad: Try alt+tabbing out of the game and alt+tabbing back in.

I was having problems with my arcade stick and controllers, and that seemed to solve the issues for some reason.

EDIT:

Also, are you running any sort of emulator for the arcade stick input drivers? It might be creating an emulated stick that’s mirroring your inputs and causing the game to think someone is trying to join on player 2 when you press start.


#15

No emulator for arcade stick, it works natively on PC and xbox360. :frowning: the only drivers i have are xbox one controller drivers i believe and maybe vjoy, but im going to delete the vjoy drivers (not that i think thats going to solve it)


#16
  • please don’t post in caps
  • you don’t have a fightstick
  • moved to tech talk

#17

-I didn’t type in caps
-I do have a fight stick
-You’re a faggot ass troll
-stfu
-kthxbai


#18

Hmm, not sure what else to suggest. Removing or at least disabling vjoy might help if you don’t need it. Capcom did advise to remove all unnecessary input devices back when people were having trouble with their controllers/sticks back in AE. Since vjoy makes a virtual joystick, it might be causing problems.


#19

That’s going to be the source of your issues right there, sir. The Xbox One controller driver is separate from the normal Xbox one. Go here:

http://www.microsoft.com/hardware/en-us/p/xbox-360-controller-for-windows#support

Pick your OS (make sure you verify whether you’re 32bit or 64), install it, restart with the stick unplugged, then plug it in and let the driver load it up. Ultra should properly ID it at that point.


#20

you guys are FUCKING awesome thank you so much, im going to do that right now and hope to god that it fixes the issue lol im pretty over getting my ass whooped all over the place online.