HELP! Qanba Q1 not downloading drivers for pc


#1

i just got this thing and want to use it now. so can someone send me a driver or tell me what to do. its the 360 version


#2

Why so many people having issues with Xbox 360 arcade controllers?

What version of windows are you using?


#3

i forget what i did but it suddenly worked. but win 7


#4

Did it started to work after you twiddled with the USB cord?


#5

haha, no. i tried my 3.0 ports, a few in the back, and finally the front panel usb. the front panel that fixed it. doesnt make sense to me. i had my madcatz te stick plugged in too and the pc noticed it and so did sf but when my friend and i started playing, it magically wouldnt do anything.


#6

I am trying to rule out if the USB cord is busted.
Troubleshooting is going though this check list from easy and most common issues to harder to fix and less common


#7

yeah, its not that cause my madcatz te worked until i plugged in the q1. idk, im just gonna download drivers for the mobo again just in case they got screwed up.


#8

So on its own, The TE is fine or it also no longer works on your PC?


#9

yeah, but now my usb 3.0 header isnt working. maybe the plug and play. its weird cause the game sees the stick but it wont do anything. i havent been home since friday, but when i get home tuesday, ill be sure to try and figure more things out man. thanks


#10

Do you have a USB 2.0 header? Use that instead.


#11

the back of the mobo has both and i tried both. the usb 2.0 on the front panel of the case, which plug into the mobo, worked. still cant use both but like i said, ill know more come tue


#12

well good news is, the q1 works with my macbook. the madcatz te doesnt cause i have the ps3 version and we all know about that crap. now i can take the stick with me to school and what not. i love this stick now :slight_smile:


#13

I know your problem is resolved but I had a shop owner tell me that it only works on 3.0 or a powered USB port. Also even if it IS the PS3 version maybe you can use joy2key or BetterDS3?