Help regarding button input issues with TE2+ on Tekken Tag 2, PS3


new to this forum, never created an account for this site, but I thought it’d be a perfect forum to ask.

First, I’ve played more than 50,000 matches in Tekken 6 and Tekken Tag 2, used Madcatz TE1 Round 1, Soul Calibur TE stick, and now just upgraded to the Madcatz TE2+. I’ve done thousands and thousands of combos, it’s in my muscle memory so much that I can do it in my sleep. My main character is Bryan for example and I use his taunt dash extensively in my game. Prior to this TE2+, I’ve had absolutely ZERO problems with the input, but ever since I switched to this new stick, the TE2+, I’ve keep getting input errors. For those who don’t know, bryan’s taunt is Square, X, and O, or in Tekken input terms, it’s 1+3+4 pressed all together a the same time, and to do his taunt dash, it’s forward, forward, 1+3+4, Forward, 1+3+4, F, 1+3+4, and so on. I can do that in my sleep, it’s very much automatic for me, and rarely make a mistake, but ever since I got this stick, it’ would sometimes come out as a 3+4, which is a another move by bryan. I’ve been trying to find out what is wrong with this stick, even tried putting a new sanwa buttons, STILL the problem persists. Also, I’ve been having trouble with 2 button inputs, for example, Devil Jin’s bound input is DF 1+2, sometimes it would come out as a DF 2 which i would NEVER EVER do even in my sleep. Is there an input lag when you play PS3 games on the TE2+? does anyone have any issues with this regarding multiple button inputs? 30% it would come out as a single button input even though I am pressing 2 buttons as the SAME time. I’ve made a review on Amazon, which is where i bought this stick, and somebody replied to my review saying the same problem, saying his Dragunov’s FF 1+2 grab is coming out as F 1,2 as if he pressed 1,2 in a sequences instead of at the same time. Also I would get commands like a sequence even though I’m pressing 2 buttons together, it would come out as 1,2 instead of 1+2. This has been extremely annoying since for example I’m going for a 2+4 grab, it would either come out as a 2, or 2,4.

I would very appreciate if you guys can tell me what the issue is, and let me know if you are ALSO experiencing this issue when it comes to multiple button inputs, whether it’s a 2 buttons together, or 3, or even 4 buttons at the same time, it’s not coming out.

BTW, I’m no foreigner to sticks and modding sticks, the rest of the stick works perfectly fine, joystick works fine, the buttons work perfectly fine when pressed individually, it checks out in the Madcatz’s driver joy.cpl, all the buttons show they are functional, the wiring is perfectly fine and connected, AND if i touch the two disconnect wires together, they work. So it issue could be “in-game”

Thanks in advance, I hope some tekken tag 2 players with TE2+ can shine some light on this.

ON a sidenote, my stick set up is Sanwa JLF, 2 lb spring, Octagonal gate, Bat top :slight_smile:


A pcb splitting button inputs isn’t completely unheard of, though the only instance I can recall is the older version of the ps360+ on the 360. Don’t the new ps4 sticks work on ps3 in either mode (ps3 or ps4)? If so, try the other mode and see what happens. Do you have a ps4 game that would be suitable to test whether or not the same issue is occurring there? Go to training mode and turn on input display, go back and forth between your sticks and see what results you get.


Do what @PresidentCamacho said and report back. That stick has a PS3/PS4 rocker switch right?
A madcatz stick acting funny in PS3 mode but being fine in PS4 mode wouldn’t be exactly surprising.
Will be interested to know your results if using PS4 mode on the PS3 works or if it solves the input issues.

You can also (if time and money permits), try buying a Hori Rap4 Kai and using that in PS3 mode on your PS3. If all your inputs come out perfectly, then, welp…we know what PCB to blame :slight_smile:


Thanks a lot for the replies guys, I’m glad somebody has seen my post so I can get to the bottom of this nightmare, ok so I did forget to add, that yes I have tried the HORI RAP 4 Kai, and the symptoms are similar, BUT it’s maybe 20% of the time as opposed to 30-40% of the time on Madcatz.

Interesting enough, I’ve tried it in PS4 mode and wow it’s like only happening 10% of the time, interesting. So I do believe it’s maybe the compatibility issue with the game? Are there any other Te2 or te2+ plus users playing on tekken tag 2? Not Tekken revolution but tekken tag 2? But what I still don’t get is when I’m doing the Bryan taunt dash, which is 1+3+4 at the same time, I would be getting a 3+4, which is his kick attack but that never happened in my old stick, it’s as if the 1 input is sometimes not getting registered or the 3+4 is somehow getting a ghost input, on my prior stick, which was the Soul Calibur TE stick, which the buttons were left stock and I used for about 3-4 years full time, it never ever happened, if I made a mistake with the taunt dash, it would come out as a 1+3 grab because if you don’t go to Neutral with the direction and press 1+3+4, then it would come out as a f 1+3 grab which is a command you can do, but never ever experienced a 3+4 coming out when I made a mistake. also, another method to taunt dash is to buffer, which is not the method I use, which is holding down 2 buttons, then F, press one button, F, press one button while holding down any of the two buttons the whole time, this method works perfectly fine on this stick but that’s not the method I do, I do the press all three buttons at the same time method which is what most top level players do when they taunt dash.

Let me know if anyone has any personal experience using the TE2+ stick on Tekken Tag 2 PSN



I’m getting the same issue but worst. I set my to ps4 mode and I get this issue 20% of the time to be exact. I spammed 1+2, 3+4, and 1+3 in practice mode. 1/5 times I get the inputs as a brush like 1~2, 3~4, and etc. Madcatz really dropped the ball this time and this is why they’re out of business


Just buy a Brook UFB and problem solved. Get the EZ Mod kit from Arcade shock. Madcatz PCBs suck anyway and this should be an automatic upgrade.


gonna try the Brooks UFB and see if the problem persists, funny thing is, ive plugged in my mad catz TE Soul Calibur 5 stick into my PS4 and tried Tekken 7 since tekken 7 supports legacy controllers, and what do you know, that button issue is COMPLETELY GONE, it’s working PERFECTLY FINE, how is it that a ps3 controller works fine on the ps4 while the TE2+ which is for BOTH ps3/ps4 isnt? the only reason i don’t want to keep using the TE1 stick is that it doesn’t support any of the inputs when in PS home page, can’t send messages or even press PS button, nothing works :frowning:

would appreciate if anyone could figure out this problem other than Brooks UFB, funny thing is, i’ve had a Razer Panthera and installed the brooks UFB with the EZ Mod, and the problem still persisted, maybe 20% of the time, i would STILL get a 1,2 input instead of 1+2 even though im pressing both at the same time :frowning:


Could also be that you need to get used to that input on THOSE sticks.


This is an issue on all PS4 sticks that I’ve seen (including those using the Brook UFB). From what I understand the issue does NOT exist for PS3 sticks.


I’ve been told that most people don’t notice this using their sticks in other games due to input leniency?


And I been told most people are hypochondriacs who report issues.
I think its all part of the human condition.


Try it yourself in training mode.


okay guys, i finally installed the UFB into my TE2+, Gummod EZPZ + Brooks UFB, UP TO DATE FIRMWARE, updated just yesterday since the new firmware was uploaded, STILL THE SAME DAMN PROBLEM EXISTS…

STILL getting 1,2 or just 1 input even though im pressing 1+2 around 30% of the times, STILL getting 3+4 or 1,4,3 command when im pressing 1+3+4…and VarnmintBaby saying its the operator’s error, look man its a little bit insulting because ive been using mad catz sticks for AGES, both Vewlix layout AND Namco Noir layout, my first mad catz stick was the TE Round 1, played close to 30,000 matches on it, same characters, same inputs, etc then switched to Soul Calibur 5 stick with the Noir layout for Tekken Tag 2, also played close to 30,000 matches total online, never had an issue, then over a year ago, when i first opened this thread, i got the TE2+ so i can get it ready for Tekken 7, then started encountering this problem, but since i knew tekken 7 will be coming out in the future, and perhaps it could be because of compatibility issue, i decided to just the hell with it and just play on the TE2+ for Tekken Tag 2 it even with the button issue, so i played over another 2000 or so matches on the TE2+, so saying how maybe im NOT just used to the stick doesn’t make sense, its only a HAIR taller than the PS3 Soul Calibur 5 stick, and wider, which is not an issue AND i also even changed the Stock TE2+ button layout to the Namco Noir layout aka the Type-N metal panel so the button layout is identical to my old Soul Calibur 5 stick, which has the buttons farther from the joystick compared to the default Vewlix layout, so the whole operator error is NOT the issue, it only took me like a week to get used to new sticks i switched to, not a whole year…these were my sticks. And look, im using the SAME chair, same stool and everything the same in terms of my placement set up. And also VarmintBaby, i’ve even tried it slowly in Training Mode, its not hard to press 1+2 repeatedly dude, nothing to do with how its a different stick or different casing or whatever, for tekken i use the Far left 2 buttons on top and bottom, so it’s not a button placement issue or anything, i pressed 1+2 repeatedly one at a time, and saw how many times it would come out properly, and it would be STILL be around 30% of time i’m getting the input error, such a only a 2 command or 1,2 in sequence.

Also another member here mentioned the same thing

he’s saying how Fang’s P+P+P is only working half the time on his TE2+.


Have you tried to change the microswitches inside the buttons ?

Maybe it’s just your square button that is faulty.


Jackals, lol dude ive had TE2 Chun Li edition, and went through like 3 TE2+ sticks, ALL with the same problem, i’ve even purchased a professionally modded TE2+, already modded with EZPZ and Brooks UFB, brand new, still experiencing same problem


Could you disconnect the turbo panel from the ezpz then try again? Wire up a button to the screwterminals if you need home.


nah dude, this is a wide spread problem, theres also a video of a guy who said he actually spoke to Markman about this and this is native to all PS4 sticks while it isn’t in PS3 sticks and mark doesn’t know why it’s happening for ps4 sticks


Take it easy man. Are you looking at the directional inputs in training mode? Tekken games have a weird way of displaying inputs. You can press FF+3+4 but the game will display it as F, F,F+3,4,4 or some weird stuff like that.If the moves you’re trying to do aren’t coming out I don’t know what to tell you. You changed the PCB so that’s not the problem. You said the buttons aren’t the problem. So what is the only variable left? I have 4 PS4 sticks, including a TE2+ with Brook UFB and EZ Mod, and don’t have issues with that input despite what markman says. My 1+2 moves all come out properly as well as other button combinations. Anyway good luck with that.


OP is talking about this


warhead your video link doesn’t work