Help: Sanwa buttons into HRAP


#1

I’m trying to get the stock buttons out of my HRAP to replace them with Sanwas. But I cant get the damn metal clips at the end of the wires to let go of the button plugs. It doesnt look like they’re sautered on, but they just wont budge. I’ve tried wiggling them back and forth almost to the point of breaking them… no luck. Has anyone tried this before? How do you get the buttons out of an HRAP?


#2

I used a pair of pliers. Hold them firmly at the end of the disconnect (make sure its not holding onto the switch too) then firmly hold the button with your other hand and push off with your thumb.


#3

i just use brute strength, I pull them off very carefully with my fingers. (pliers can be used too)


#4

Just a tip - I guess you already know this, but I had to open my HRAP twice the other day, because I didn’t click the disconnects on my replacement buttons.


#5

Get a flat headed screw driver and prise them off. They’re quite hard to remove at first, but you’ll find they’ll be a lot looser the second time you come to remove them.