HELP! slow SSF4AE PC


#1

does anyone else have this problem or have an idea as to what the problem is? i havent seen anyone post anything like this in the forums

I just installed SSF4AE for PC purchased through steam and i get EXTREMELY SLOW gameplay. This isnt even just isolated to the game, its even slow navigating the basic menus, going into options, etc etc. it literally took me 15 minutes to change my graphics settings. Because it was running so slow I resorted to turning all my graphics settings to the minimum, even 800x600 resolution and every option off. I ran a benchmark and the displayed fps on the top corner keeps changing sporadically from extremely high and extremely low.

http://imgur.com/T0ScF

and it was acting the same way yesteray night when i ran it at the default settings

Here are my PC specs

Windows XP home editioin SP3
e6600 core2duo 2.4 ghz dual core processor
4x1gb ocz gold pc6400 ddr2 ram
foxconn g33m microatx motherboard
HIS Radeon HD 4850 IceQ4
500 gb hd

and these are all of the things i tried in order to fix it but im all out of ideas.
Update my graphics drivers
update directx
minimum settings
create a backup, delete local content, and reinstall game (i didnt re download through steam because it took me 12 hours to download all 9 gb…)

Also please keep in mind that i have SF4 vanilla through steam as well and i actually have it on all maximum graphics settings and i get A on the benchmark tool as well

If anyone has ideas please help. Ive been at it for at least 7 hours and im pissed and tired as hell


PC: Getting better FPS in SSF4 AE
#2

Hi there, my friend had a similar issue with his machine and scoured the internet, came across the following solution which worked for him:

  1. Head to your Documents\CAPCOM\SUPERSTREETFIGHTERIV folder
  2. Open up the file config.ini with Notepad
  3. Change the line:

RenderingThread=ON
to instead be:
RenderingThread=OFF
4) Save config.ini, reboot SF4 AE, see if it is all better

Hope that does the trick!
**
**


#3

hey thanks! it helped with navigating my menus, but now i have a new problem. Any mode i attempt join which has a character select screen crashes the game. that means no arcade mode, no versus, no training mode etc havent tried GFWL battle yet though. ill try it now

the one thing that did seem to work was the trial section…

edit: yeah even my gfwl matches crash. also the benchmark runs in SUPER SPEED. like it starts and ends in 10-15 seconds instead of playing the demo match in realtime


#4

This is why games consoles have the higher market share. Get it for the 360 or ps3.


#5

OH WOW THAT’S GENIUS CAUSE ITS COMPLETELY ON TOPIC AND HELPS ME FIX MY PC VERSION.
if you have no productive suggestions about the topic at hand don’t be a prick about it, you dont have to reply to this thread in the first place.
And by the way, i do own it for 360.


#6

If you set the video mode to Fixed frame rate, you won’t see the demo in superspeed, though I do like the 200 fps oni battle :slight_smile: Some folks on the Steam forums are also reporting the same crashing issue, you might try there.


#7

ah i see is it like that for other people? cause mine is set on fixed frame rate and still goes super speed. also certain load screens get stuck unless i minimize/maximize…

edit: http://www.youtube.com/watch?v=jX7e6Lo5QL4


#8

Heres a quick update on my PC issues.

In in the config.ini file i turned RENDERTHREAD = OFF and i can now navigate menus without horrible horrible .2 fps lag
but now my game constantly crashes if i try to join any mode with a character select screen

it crashes when i try to start arcade mode, versus mode, training mode, and on GFWL battle i can join peoples lobbies but once we both press ready my game crashes. also the benchmark tool runs super fast like in the video posted above. The only thing i can run are the combo challenges

anyone have a similar situation or solution?

EDIT: also when i toggle RENDERTHREAD = ON it behaves exactly as it used to. does anyone know what is going on or what exactly renderthread is? it may give me some clues as to why its crashing


#9

D3Doverrider is your friend folks!!!

It’s part of Rivatuner which can be had here: http://www.guru3d.com/index.php?page=rivatuner


#10

I have the same problem! Menus and the game were lagging horribly, tried setting rendering thread off, now I can navigate menus normally but it crashes when I go to a character select screen :frowning:


#11

I’m having slow-downs, but nothing like what I saw in your videos, kpxcho.
I believe my problems lie in the GPU overheating (Radeon HD 4600 series), but I can run SF4 for hours on end without a single hiccup, with the same settings. The temperatures go up to the same level in both games, as well, but again, no issues with SF4. That game runs like a dream.
What the heck is up?


#12

Hey i have Radeon HD 4600 series as well… having the same problem when i did a fresh install of windows XP cuz i couldn’t do GWFL updates with my last OS, i set everything to Default on my graphic card settings especially unclicked Triple Buffering in the settings and my Frame Rates are steady in the benchmark about 75 fps on 1366x786 with everything on high No AA, Prior i had triple buffering and everything torward performance and i had 50 fps per second and sometimes it shot thru 100 fps so it was really unsteady, made the game run really slow and hiccuped alot… hopefully this works for you!! so far it’s working for me


#13

this happens when you have the xbox360 controller emulator and you plug in a fight stick
you need to remove the xbox360 controller emulator and it will work
i had this too


#14

same problem no solution yet.im on core2 duo,8800 gts,3gigs ram.xp.strangly enuff i got the game to play 1 time in multiplayer.then after i started up agian same crahes.i tryed every solution ifound online nothing.tryed every resolution and ever possible graphical setting.no i dont remember how it was setup when it worked.


#15

Has anyone found a solution to this? Things i’ve tried:

-Disabled the Aero Theme for Windows 7
-Turned in game vsync off and changed to “fixed” Framerates
-Enabled vsync through D3D Overrider
-Smart Defrag
-loaded latest drivers for graphics card
-Reloaded DirecX 11
-Tried using several different “game enhancing” software like Game Booster
-RenderingThread to OFF
Nothing has worked. I don’t know what else to do. My benchmark says i’m running at around 8-10 fps (?!).

Now mind you, I have no issues streaming live video using my Hauppauge HD PVR. I can watch a movie while I render 2 videos in Sony Vegas all at the same time. I can play every other game I’ve tried no problem. Just no SSIV AE… Here’s what I know about my system:

Its a Toshiba laptop

Windows 7
Intel® Dual core running @ 2.2ghz
4 GB RAM
500GB HD with about 300 GB Free
Intel® Graphics Media Accelerator

Anyone solve this problem? I’m going on a trip and would love to play SSIV AE on my Laptop. I have it for 360 and PS3 already but i’d really like to avoid packing them up… please help…


#16

Have you updated to the latest version of SF4? Capcom released a patch for PC a while ago which addressed some issues(not necessarily those you are seeing but it’s worth a shot.)


#17

Hmm No I just installed the game and tried to run it… I wonder. I will look for the update. Do I get it straight through the game or have to search to download it somewhere?


#18

My PC should run this game perfectly. However, I have FRAPS on and it always shows that my game is running at 50fps. Isn’t it supposed to be 60? When I play in Trials mode, it runs perfectly, but when I go to online it’s all perfect connection but I still get a slow-motion game. My PC specs:
Processor: Intel® Core™ i5-2300 Quad Core 2.8 GHz
Graphics: Nvidia GT545 1.5GB
RAM: 8 GB DDR3

When I turned everything on low and “off” what was possible to turn off, benchmark gave me 300fps, but it’s still slo-mo in GFWL. This is not supposed to happen…


#19

turn limit framerate off in fraps


#20

Alright, I fixed the problem. I went into the game config and changed “RenderingThread=ON” to “RenderingThread=OFF” and turned off Vsync and now when I run Benchmark it gives me 100fps with everything else on best.