HELP! TE Fightstick not working anymore!


#1

Hi mates,

Well, I really need your help. Three weeks ago, I bought a XBOX360 MadCatz SFIV TE Fightstick.

I was very happy with it, but unfortunately it stopped working yesterday.

It was my fault, because I accidentally pulled the cable (I didnt notice it got hooked and when I stood up the cable suffered a jerk). It seems something from inside has been disconnected.

Now, when I connect the fightstick into the front USB port, the XBOX360 button flashes half a second (as usual), but when I press the button to turn on the console, or to make the console recognize it, nothing happens.

I have also tried with both USB ports, meaning that the problem is in the fightstick.

So, in resume, the fightstick receives power from the console but the console doesnt recognize it.

I have wrote a mail to MadCatz Support, but still no response.

Could somebody help me?? should I open the fightstick and see what happened inside?? Is there an easy fix for this issue??

I am quite worried about it… :sad:

pd. Take care with TE fightstick cable!!! a little jerk can be enough to f**k it, it seems…


#2

I just got my TE yesterday so Im no expert but I’ve heard that if you open it up you will void your warranty…it might be bettter if you just send them another email or wait until they reply, I emailed them about a week ago to ask if the 360 version was 100% PC compatible and I got a very helpfull reply within 3 days detailing exactly where to get the drivers from etc.