Help with P2P Kaillera in MAME


#1

Hi.

My friend and I can get P2P Kaillera working in MAME(vers. 117) the very first time we both open up the client and the game starts fine. But after that, every other time we play, one of us gets a black screen, with a message saying “Press [Y] for Ending”. Once that happens, I(or he) cannot exit out of that screen no matter what. Not even Alt+tab or Alt+Enter works. I(or he) has to restart my entire PC.

We both have ports 27886 as exceptions in Windows firewall. He is on a router and I am not. Does the 27886 port need to be forwarded on his router? He as ATT DSL I am on cable.

O746 since you made this client(which is awesome once it does work), can you please tell me how to resolve this issue or work on a fix? Why do we get this black screen after it works the first time?

Does our Anti Virus program need to be turned off as well? Really don’t want to have to do that.


#2

Mame 117 gets that error all the time. You have to virtually restart the client every time you end a game in 117 whether you’re in a server or doing p2p, but you shouldn’t have to restart the PC. When you see “press Y for ending” it means you aren’t even connected to the other player(s).

The bug is independent of your ports and antivirus, because everyone encounters it. It may have been fixed in 119, but I haven’t tried it. It doesn’t occur all the time though, so I’m not sure what causes it, but traditionally anyone on 117 will restart their client when they end a game.


#3

It was fixed in 119 but no one uses it because they refuse to upgrade. If you want to play with anyone you’re forced to use 117.


#4

Thanks for the replies guys. Just to clarify however, the bug was not eliminated in 119. In fact, we moved down from 119 to 117 because of the very same issue.

You correct in that restarting the client is required but what’s also required is restarting MAME itself. Meaning we have to close everything down then restart. Pretty annoying.

Does 116 contain this problem? If not do you recommend it? How about any MAME after 119? Any of them have Kaillera support?

By the way I have another unrelated question:

Does the P2P version of Kaillera support 2-player TAKE TURNS-type games MAME?

My friend and I tried playing Ninja Princess, Kung Fu Master, and Vigilante, all of which are 2-player “my turn/your turn” type games. We got the games to run but the funny thing is, despite him being able to “insert coins” and pressing start, he could not control the 2 player character.

Problem with his gamepad mapping settings or a P2Pk compatibility problem?


#5

It depends on the cabinet of the game you are playing. Many 2 player take-turns arcade machines only had one joystick and two coin slots. To take turns you would have to let the second player on the stick after you died or completed a stage. Mame emulates the same concept, except it isn’t smart enough to know when its player 2’s turn.

http://www.klov.com/game_detail.php?game_id=8361

As you can see, Kung-Fu Master only has one stick. In order for your friend to play, you would have to F5 swap him when its his turn. (2134)