Hitbox(Fightstick) Unknown USB on PC


#1

I’ve had this for a few months, and I don’t know how to get it to work on my Laptop.


#2

Which model is it, ps3 or ps3/360?


#3

You need to put up more details in order for us to help. Model type of HitBox, OS, etc.

Is it a new laptop? Are the ports USB 3.0? If so, you’ll need a 2.0 based hub most likely. Many HID products are supported by USB 2.0 but they have issues on 3.0 ports.


#4

It is the MultiConsole version(hitbox). I think it uses PS360+ or something like that. I’ve had this laptop since January.
The laptop has two 2.0 ports and a 3.0 port I believe. I get the same response from all ports.
p.s.- I just plugged it into my friends Desktop and it worked, but I want it to work on my Laptop


#5

#6

I don’t know how to set it into a Ps3 or Xbox mode, but I can get it to say Bootloader and PS360+1.2v. PS360+1.2v shows the Yellow Exclamation at times.
I tried holding down random buttons before, but still says Unknown USB. The cord length is only 10ft.


#7

Try holding 1p (x/square) while you plug it in to force ps3/pc mode.


#8

still Unknown USB Device


#9

All the modes are listed here:
http://www.akishop-customs.com/PS360Plus/PS360SoftwareOverview.pdf

To put it into 360 mode you hold medium punch (2P) when plugging it into your PC. Does it come up as unknown still? Sometimes that helps. Only 1P and 2P will do anything, the rest are for legacy systems it seems (save for original xbox, but doesn’t apply here anyway).

If you’re getting a yellow exclamation, what happens when you try to find drivers? Still nothing?

I’d go two routes then:

  1. Try a powered hub, it can sometimes help
  2. The cable might only be 10 feet, but that’s usually a maximum anyway. If you can, I’d try shortening it to 6-8 feet and test it again.

#10

I held down 1P and tried multiple Usb ports 15 times on my Laptop. I got 13 Unknowns / 1 PS360+ with Exclamation and 1 that actually works FINALLY! 1 out of 15 isn’t good.
I held down P2 and got 15 unknowns. Guess I should still buy a shorter cord and a USB Hub?


#11

You should upgrade the firmware to 1.4.

There were a few changes made to the usb settings.


#12

My Laptop doesn’t allow Upgrading


#13

Changed the cord, it’s been working perfectly since. TYVM