Hori EX2 Mod - Some Buttons Not Working


#1

Hey guys, was wondering if I could get some help here.

I modded out the buttons on my Hori EX2 stick. Replaced them with Sanwas, and I just finished soldering them in. The B, X, R, and LT buttons work. However, the Y and RT buttons aren’t working (Heavy Punch and Heavy Kick, traditionally). They do not register, tested it in SF4 and Dirt 2’s button config.

I thought this was really weird because Y and RT were the easiest to solder on and desolder the old buttons.

I tried resoldering the Y and RT buttons on just to make sure I didn’t do a whack soldering job on those, but they still don’t work. Also tried rotating the buttons, I knew that wouldn’t do anything, but it was worth a shot.

Is it possible I damaged something on the main board or severed a connection somewhere or something like that?

Sorry I can’t get pics up yet so that I can help you guys help me… If you guys really need pics to be able to help me then I’ll see if I can borrow a digi cam from a friend, but from what I see, it just looks the same as it did, all of the solder points are the same.

Thanks in advance!

Edit: Nevermind, I just decided to solder those buttons to the LB and RB solder points and it worked fine.