Hori Fighting Edge on PC Completely Nonfunctional


#1

No power lights or anything, it’s totally unresponsive. Windows 7 can’t find any drivers for it, and a Hori rep just confirmed via email that there aren’t any period. Yet I’ve seen people on this forum mention using Fighting Edges on computers (and having further problems that at least imply it could plug in and have the buttons work).

So apparently it’s not the best stick for PC use, but is there anything I’m missing to at least have it respond when plugged in? Any help is appreciated, I really want to throw down on Steam!

(Hori fighting edge Xbox version, Windows 7 64 bit, Intel PC)


#2

Check your USB cord. Your USB cord is damaged, hence why the PC will not detect the stick.


#3

It does detect it as a Fighting Edge, just doesn’t do anything with it. But I’ll take a look anyway

Oh yeah, also it still works on my Xbox, so I don’t think it’s the cord


#4

yea it’s not the cord. sadly the xbox 360 version doesnt work on pc. (I too have this problem)


#5

When using an arcade stick on my PC, I have to use one of those four-cable cables, that have two ends to put in the PC USB ports, as the front USB ports do not supply enough power.

Have you tried your rear USB ports?

I hope what I said makes sense…


#6

So the fact that it sees it as a Fighting Edge is a good thing… Sort of. In my experience, I found the issue to be more with Windows 7 than anything else. Here’s what I did to resolve my issue on my MacBook Pro under Windows 7, 64-bit:

When I originally plugged my stick in, it identified it as a “Soul Calibur V TE”. Like you, it didn’t actually work in anything, because it needs to be recognized as an XBox controller for Windows.

  • I downloaded and installed the Xbox 360 Controller for Windows driver software available by searching for it on the Microsoft website.

  • After installing the software, plug in the stick. You will find that it still doesn’t work.

  • Go to the Device Manager, and look for the stick. Right-click on it and select “Update Driver”.

  • When the wizard starts, you have two options: Automatic detect, or Manual setup. Choose manual setup. During the process, you should be able to select gaming devices, then XBox 360 Controller for Windows.

  • After the wizard completes, disconnect and reconnect your stick. When completed, if you look under “Devices and Printers”, you should now see “XBox 360 Controller for Windows”. At this point, your stick should be usable in your Windows games!

This was my personal experience with Windows 7… On my Windows 8 machines, both my TTT2 and SCV Mad Catz sticks worked with no problem. Because your Fighting Edge is a licensed stick, it too should register as an XBox 360 controller, once the installation issue is resolved.

Keep in mind that I don’t think that the lights will necessarily work, and if the blues light up, don’t expect the reds to… It’s my understanding that the red lights up based on rumble feedback, and rumble was never implemented into the Xbox 360 driver for Windows. If the stick doesn’t light up, verify in the Device Manager or Devices and Printers windows that it is properly installed. If it doesn’t show up as an XBox 360 Controller for Windows, chances are that it WILL NOT WORK.


#7

The 360 Fighting EDGE is designed for the Xbox 360 console and was not intended to be used on the PC. Although the product may be recognized by the PC, we do not have any drivers available to make this product operational on the PC. Additionally, we do not support any third party drivers that may enable this. However, as @playdoh003 explained, since our product is an officially licensed product, by installing the Xbox Controller for Windows driver it should work but we cannot guarantee this… We apologize for the inconvenience and ask for your understanding.


#8

I just want to share that I recently purchased Fighting Edge ps3 version and for my macbook I just plugged it in and everything got installed correctly. I still advice to check out “Set up USB game controllers” and see if you can find the stick when its plugged in and check if buttons work, too bad home key wont work on the stick for ps3 version


#9

Home key is only supported by Xbox 360 controllers for PC games that run under the Games for Windows Initiative.
Hori PS3 controllers are treated as generic HID class devices by windows; Mac OS is very good at running device drivers so a generic HID class driver isn’t an issue.

As the Hori rep stated, Hori (as well as any other manufacturer) will not guarantee the device to run well under Windows (unless the said device is licensed to run in windows). It is more of a liability issue.
The Fighting Edge (Xbox 360 version) is a licensed Xbox 360 device and so its complaint to Xbox 360, Windows compatibility was not part of their concern. According to popular theory the right combination of various brands of PC hardware causes undocumented incompatibility issues, undocumented because all of the variations of hardware and software fragmenting the PC market.

It is worst with Linksys routers and the Original Xbox, they are not very compatible with each other for no clear reason. Linksys insist that Microsoft must fix the issue as the Xbox is a MS device while Mocrosoft blames Linksys.


#10

Thanks lol ****


#11

My stick has always been working but this last reformat it started giving me these issues.


#12

I bet you its a driver issue, this might not work but hear me out on this
Did you download and install Direct X 9.0c ? Often programs and drivers look for older versions of Direct X files and it will not over write your newer Direct X 10, 11 or 12


#13

so I randomly decided to plug my 360 version of the Fighting Edge into my laptop today…and to my surprise. it not only works (on windows 10), it works 100% including the lights & touch pad…and without even installing a driver. so apparently windows 10 fixed the issues we once had. just thought i’d necro this post & share.


#14

ill try the 9.0 c i had to reformat again and everytime im on windows 7 it never picks it up but if im in windows 10 it works.


#15

Ask here:


#16

Ok this is the proper way to fix it btw make sure you follow step 4 thats where i fixed it at.