Hori Fighting Stick 3 PC Compatiblity


#1

I plugged my HFS3 into my PC, which sees the HFS3, but does not recognize any inputs. Found a driver on virtuafighter.com fourums, installed it, but got one of the possible errors.

Anyone know how to get the HFS3 inputs recognized by the PC?

PC is running Windows XP SP2.

I have no driver writing experience for PCs. Any tips on that would be appreciated.


#2

With the HRAP3, the stick doesn’t get directions read on pc unless you put it in the mode where it’ll read the left analog stick instead of leaving it digital. There’s a switch you have to toggle at the top left, although on the ps3 you’d want to leave it on digital.

Since this is a Hori stick, I figured it was the same way.


#3

Don’t see a switch…thanks, though.


#4

you need special drivers for the fs3

try searching google for it


#5

I’ve been all over google…couple of days, in fact. That’s why I made the thread, so that if anything new does come up, it can be placed here.

That’s actually were I found the driver, but it only works for some, and not for others.


#6

yeah, it doesn’t work. there’s a poster called rale on the virtuafighter.com boards who made drivers, but it still didn’t work for most people.

you can try em anyway, you might be one of the lucky ones

http://rapidshare.com/files/22348021/fs3drv.zip.html


#7

Those were the drivers I tried, and I am one of the unlucky ones :wasted:


#8

I just got mine the other day, and unfortunately mine doesn’t work either. I’d kill for this to get working on MAME.


#9

Bump


#10

Mine worked pretty much right out of the box. Vista recognized it and installed the drivers automatically for me. I do have the xbox 360 remote adapter installed as well but that really shouldn’t have anything to do with it.

I’ll try hooking it up to my laptop (also has vista) and see if it does the same thing later on today (I’m at work right now)


#11

edit: my bad thought it was a ps2/ps3 stick only


#12

^huh?

it’s a usb stick.


#13

I have a hunch about why it works. What processor are you using on the system that it worked on?


#14

AMD 64 5200+ (Socket AM2)

My laptop is a Pentium M 2.0ghz and I also have a regular xp box that has an AMD 64 3000+ (socket 939) that I can test it on as well.


#15

Remember to push the PS/Home key before you try to use it


#16

Tried that, no dice.


#17

It’s interesting because I tried it on a AMD 64 too, and it worked. None of my 32 bit systems worked.
When investigating making a driver for the FS3, I found out that it was not reporting in the right addressing mode. Infact it was using 64bit and not 32. It is possible to tell the stick to change modes, but it does require a new driver.


#18

I’ve only heard of the driver mentioned above in this thread. Any luck on said new driver?


#19

I stopped working on it for the summer, since I have other work to complete. I’m willing to give it some effort, but I just don’t have the time to do the research on programming USB drivers.


#20

Ok, I did a little research and the person who programmed those drivers used Windows Driver Development kit, and the driver calls for a file in the development kit, hence why it wont work, I’m going to install vista on my laptop and see how it works on it