Hori Fighting Stick V3 controls getting "stuck" on PC


#1

Hey everyone,

I decided recently to get my first arcade stick. I ordered a brand new Hori Fighting Stick V3 and I really like it so far…

Except now all of the buttons are “sticking”. Basically, if I quickly tap any button (or any direction on the control stick), the controller sticks on it as if I’m holding it down for about a second. While that happens it doesn’t read any other inputs. It’s almost like it freezes every second or two.

I checked all of the turbo switches… Nothing seems to be turned on. Anyone have any idea how I can fix this issue?


#2

I’m actually having a similar problem with my hori V3-SA stick I just got except on PS3. I’ll be playing fine and all of a sudden it will freeze up and nothing responds, So if I’m crouching down the character is stuck like that and nothing on the stick works until I unplug it and then plug it back in.

I can play for a few minutes before the problem repeats itself.


#3

Hm… Yeah that sounds like a similar issue. Unplugging mine doesn’t fix it though. When did you purchase your control stick?


#4

Is the button plunger physically sticking down when you press it or is does the button appear to be working correctly mechanically but the input is being held down?


#5

Thanks for the response. The buttons all appear to be working mechanically. The input is what is held down. I played some more with it today. It was find for about an hour then the problem arose again… Really weird.


#6

Try taking the plunger off and cleaning the inside of the button. Especially if you bought the stick used, there tends to be a build up of people gunk inside of buttons. Sometimes this gunk gets into the switch and makes it stick. There are two small tabs holding the plunger in on perpendicular sides to the tabs that hold the button itself in (assuming these are snap-in buttons we’re talking about). Just press those in with something to remove the plunger. You can use 90 percent alcohol on a qtip to clean the button and switch. I recommend holding the switch upside down and cleaning it from the bottom to avoid getting any moisture inside the micro. Let us know if that’s the problem.


#7

I appreciate the response but that doesn’t seem to be the issue–the controller is basically brand new and this issue persists through every single button and the control stick.


#8

I just got a V3 as my first stick as well, and I’m having this same problem. It isn’t consistent, and restarting SSF4AE usually fixes it, if waiting a few minutes doesn’t.

So far, it’s worked fine more than it’s worked poorly, but every now and then my inputs will either stick for 2-3 seconds or take as long to register.


#9

Hm… Interesting. Which windows are you using?