How am i going to remove the wires off this?


#1

notice no tabs or anything to push its literally just flat?

i have 2 other atroxs next to mine and me and my boys are puzzled were about to just throw it away.


The Razer Arcade Stick Thread!
#2

#3

They are quick disconnects. Pull from the plastic sleeve or slide that up and grab the metal connector and pull directly out… Easier to do with needle nose pliers.


#4

dude there are no tabs no holes nothing its jsut flat if i pull any harder i will be pulling off the gold crap on the sanwa its self i have two atroxs next to me both have small holes and a tab i can get with my fingernail nothing like that on my atrox


#5

pull harder


#6

bro i already broke one of the godl pieces off… the sanwa button its self and it still didt come off i pressed everywhere there are no tabs no holes nothing the gold shit from the sanwa button is really pinched in the silver wire tubes it wont release

6 people who been modding sticks for 12 years cant even get it


#7

they cant grab a pair of pliars and open up some quick discos that look like they have been crimped? yikes


#8

notice how there are no holes ont he other side there are no tabs its flat like flat flat


#9

heres an atrox sitting next to me mine looks nothing like this its just flat no tab nothing just flat


#10

SMH… take pliars, squeeze opposite of the crimp (see that line in the middle???) that someone did to them… grab a jewlers screwdriver and open them up from the backside if needed.

The holes mean nothing.

Fire the modders.


#11

dude i’ve tried plider broken 3 of the pieces off i’ve tried screw drivers nothing these fuckers will not come off period period like its just stuck like its glued in


#12

mine dont have a grimp its just flat the others are not mine mine are flat i dont know how else to explain it


#13

Take an electronics screwdriver, stick them within the quick disconnects, where the curves are in the quick disconnects, and wedge it, so that the quick disconnects loosen up around the tab. Then pull them off.


#14

if you and the “modders” cant do it you can:
[list=1]
[] Cut the wires and put new disconnects on and get new buttons.
[
] Throw away the stick… cause the internet people werent helping
[*] Hire a real modder that could figure it out just as easily
[/list]


#15

thats the best i can get notice how they dont look like the examples i’ve shown i’m stumpped i done everything possible the white piece that looks like silver sticking out is cat hair lol


#16

Literally the post above yours says

As a side note, the crimp job on those QDs is ultra shitty.


#17

yeah but why dont mine have quick disconnects tho? why is my atrox different from the 3 other examples? do you guys get what i mean? those ridgies you see are scratch marks from everything i’ve tried.


#18

Those are quick disconnects. They’ve just been so poorly worked with that you’re having a hard time taking them off.


#19

if i pull any harder the gold thing in the micro switch are going to come off… i have tried everything… literally pliers nothing tried a knife paper clip phillips glasses screw driver and a flat head i pushed on both sides pulled as hard as i can go

i have inprints in my fingers my wrists are tired from pulling and tugging…

i dont get it honestly i don’t my te all i had to do was touch the tab and it came out these its just flat nothing to press in


#20

someone circle wtf im suppose to be touching or what ever.