How to setup your Linksys WRT router for PS3 - Warning lot of pics


#1

This guide was originally written to help srk member danomighty. I’m extending it to all members. This guide assumes that you own WRT54g. It can be tweaked just a bit to work with other routers. Basically this guide will help you properly configure your linksys router so that you will able to connect to PSN network to play games, with your PS3. Without doing this, you may able to sign in to PSN network but you won’t able to play games with other members.

I’m going to assume you have default Linksys configuration - meaning you may have changed your admin password for linksys but did not have any other IP settings changed.

First Step - Change your IP on PS3 to static IP. This will make sure that you PS3’s IP address won’t change. You don’t want it to change since you want to always forward the ports to this IP address from your router. For this demonstration we’ll set the PS3’s IP as 192.168.1.10 - will not work on DLINK or BELKIN cause of the network ID is different.

I’ve chose 192.168.1.10 however you can choose anything out of the DHCP range (automatic way of your router assigning IP addresses to your network devices, including your PS3). For linksys the default DHCP range is 192.168.1.100 - 192.168.1.149.
You can choose from:

  1. 192.168.1.2 - 192.168.1.99
  2. 192.168.1.150 - 192.168.1.254

Pictures says it all:

http://i28.tinypic.com/2cgkhv5.jpg

http://i26.tinypic.com/2i29zy9.jpg

Just make sure internet connection is enabled before proceeding to Internet Connection Menu.

http://i28.tinypic.com/2afekg0.jpg

Next Menu - Configuring IP for PS3.

http://i31.tinypic.com/23w5krk.jpg

http://i25.tinypic.com/2gweyc3.jpg

http://i30.tinypic.com/oqj6n5.jpg

http://i31.tinypic.com/op73ah.jpg

http://i30.tinypic.com/11jm06u.jpg

http://i28.tinypic.com/2niyydi.jpg

http://i31.tinypic.com/33w8dhk.jpg

http://i25.tinypic.com/1zdbzb4.jpg

http://i30.tinypic.com/x1jdw6.jpg

http://i30.tinypic.com/2rzrxiq.jpg

http://i32.tinypic.com/swwnqe.jpg

http://i26.tinypic.com/1on2aq.jpg

http://i29.tinypic.com/2rpuyp2.jpg

http://i31.tinypic.com/2q24p5e.jpg

Second Step - Change your Router settings to forward the correct ports to your PS3. Forward the ports below - PS3 is expecting game traffic on these ports that it is listening on. In your web browser type http://192.168.1.1 to access your LINKSYS router. Type in your credentials - if you never have logged in to your router before, refer to your manual for the default password for admin (manual also on linksys site).

This screenshot shows default IP addressing config for the LINKSYS box:

http://i28.tinypic.com/2i725ab.jpg

Make the changes like so: - you only need to forward these ports pictured below, NOT 80, 443 and 53!!! Don’t believe me? Without forwarding any ports, you should able to sign into PSN network, browse and download demo game through PSN network. For the application name, you can name it anything - its for your reference.

http://i28.tinypic.com/2hga9m9.jpg

I hope this will help you guys out… :tup:


Info Thread: Rules, FAQs and Tutorials Inside. (READ THIS BEFORE HITTING THAT NEW THREAD BUTTON!)
#2

Say I have a wired router, But I’d like to improve my connection. Would port forwarding help? It comes up as a nat2 in the ps3, Does it need any improvement?


#3

^ Yes, Mystic.

By the way, this thread has been stickied for quite a while.


#4

Port forwarding, will not “improve your connection” per se - meaning it won’t optimize your traffic as in “make it go faster.”

Port forwarding will help you resolve this problem and danomighty descibes the problem the best (when not using port forwarding) -

:rofl:

The stickied guide by all means is a great guide in general. There are however few minor flaws. Problem with the stickied guide will not mention to use static IP address or how to assign one. Secondly, the port forward section for XBOX and PS3 is wrong and inconsistent. Take for example in that guide the ports that it wants you forward:

XBOX Live

TCP:
80
3074
53

UDP:
88
3074
53

PS3:

TCP:
80
443
5223

UDP:
3478
3479
3658

You do not need to forward 80, 443, and 53. XBOX and PS3 does not have a listener service on those ports, they just need to opened for outgoing traffic - linksys, dlink, netgear, belkin, and whichever home router you use, the default rule is that all outgoing traffic is opened… Without doing ANY port forward you will able to browse the market place and download demos without any problem using port 80 (http) and 53 (DNS). The reason why you need port 443 (https) is for online payments. What’s inconsistent is that if you do need to port forward these port numbers, how come port 443 is missing for the XBOX live? Xbox live uses port 443 also in order to take your credit card info to process transactions if you so choose to do it from the console. Also for PS3, you are missing port 53 (DNS)? Without DNS, your console will not able to find the PSN Network.

The truth is you do not have to forward 80 ,443 and 53. You only forward the ports where the consoles are expecting the ports to be opened for incoming traffic.

So in order to help out danomighty, I’ve created a step by step guide for the WRT54g router regarding PS3 network config to make all this confusion clear. :rofl:


#5

Yea I actually didnt use those, I looked up blazblue on portforward and just used those ports.


#6

Portforward guide also has it wrong. It wants you to forward port 80 and 443. And as for the blazeblue ports, those are just PSN network ports.

http://www.portforward.com/english/routers/port_forwarding/Dynamode/R-ADSL-C4/PS3_BlazBlue.htm

Note besides 80 and 443, which your PS3 is not running web or dns server, all other ports are the same as the PSN network ports.


#7

If you have a nat type 2 then your connection is open. To get a nat type 1 you would have to be directly connected to the internet without using a gateway or router, for instance connecting your ps3 directly to your modem (assuming it doesn’t have routing capabilities).

Nice writeup captn,

I’ve got my ps3 on dmz, which gave a nat type 2 but i have some error saying that my router may not support packet fragmentation or something like that. Any ideas? I’ve tried all kinds of things like adjusting my MTU, but no luck.


#8

dj-blitz, let me try to help you. What is the current symtom right now?
Are you able to play PS3 games?

Also for the error, can you write it down and give exact error message? This would help me to help you. :rofl:

oh btw, although the PS3 might detect NAT2 when putting your device onto DMZ- putting your device onto the DMZ technically works like having a NAT1 - you are putting your device “outside” the firewall. Its a one to one NAT vs. Port Address Translation for all other devices behind a NAT. That’s why the need for port forwarding - static PAT (when not utilizing the DMZ).

That’s why when kooper wrote this “guide to improving…” sticky, he mentions there would be security risk if you were to put a PC on the DMZ. Since the gaming console is an appliance, he says it is safe - nothing to hack like MS OS.

Edit
The same DMZ rules don’t apply to enterprise devices like CISCO devices. You need to explicitly tell the router/pix/asa to open the ports even on servers that are on DMZ.


#9

Thanks for the info, I would never put my pc on dmz. Although I know many people that do, even people that were in my ccna classes, which baffled me.

I can play games fine, but I’m afraid that my router may be dropping packets resulting in lower performance than I could be getting. I don’t have the fastest internet connection so every little bit counts. The error I get is “The router in use may not support IP fragments, and the communication features of some games may be restricted.” I’ve tried lowering my default MTU value with no luck. I’ve got a WRT300N router. It seems to be a fairly common issue but I haven’t found any fixes.


#10

Well you did the right thing to adjust your MTU values however the next step might be asking your ISP for MTU value. Let me know what happens.

As for your CCNA test, you need to take your board (which they provide you during testing) and write down your subnetting before test begins. When you get nervous, you start to forget your subnetting. Lot of the CCNA questions force you to see if you are in the correct subnet before answering any questions.
Learn to subnet NASCAR FAST=-

Also understand its not like MCSE or A+ test. You can’t go back to the ones you already have answered… not that you have time to go back anyway. :rofl:


#11

I used to have the IP fragmentation issue with my Tomato router and it turned out to be caused by the ‘Inbound Limit’ setting under QoS. This setting limits your download speed and I had to turn it off to solve that problem.

Maybe your problem is caused by something similar in your router settings. Try turning off different options to see if it helps.

I think the only port the PS3 really needs for PS3-to-PS3 connections is the port UDP 3658. The port 3478 seems to be used for contacting PSN STUN servers which help the consoles to connect each other.


#12

TheWeakOne, that is an excellent suggestion which I haven’t even thought of. Of course depending on what firmware DJ-Blitz is using he may not have the option.

One thing I did forget to mention is that MTU are the lowest common denominator so they all have to match the ISPs MTU - (your router and PS3 can go up to 1500, its your ISP that’s in question.)

Anyhoo, if you want to pre-test your ps3 and router, just set it to 1400 MTU for both devices. 1400 cause I highly doubt your ISP’s MTU will go that low… remember the packet has to equal or lower than the ISP’s.


#13

Well, I’m not currently running any custom firmware, but my router does have some QoS options. However, it does not have an inbound limit setting.

As for the MTU, I tried lowering it again just for kicks, but no luck. I’ve contacted my ISP in the past. The people I talked to were pretty ignorant and unable to give the information I needed. So I used the ping-f-l command in windows to calculate my max MTU. I believe the highest I could get without timing out was 1472.

My modem is also a router and I got the same error on it before I purchased my Linksys. So I doubt it’s a router specific problem. Currently my modem is in bridge mode and I’m running a PPPoE connection on my Linksys. The only way I’ve found to get rid of the error was to set up my ps3 using PPPoE and connect it directly to my modem (while in bridge mode), which gave me a nat type 1 with no error. Although I’m not sure if there are any problems that can occur using PPPoE with your ps3.

As for the Cisco cert. test I haven’t taken it yet. It’s one test I’m not looking forward to. haha


#14

Have you tried putting the PS3 on 1472 MTU along with the router? Its important that both device should match. It almost sounds like automatic settings don’t automagically detect the settings needed. Around the interenet forums, some companies admitted that their router is having problems and the only way to get rid of it is to get another router. LOL

Try reviewing your CCNA by reading CCNA cert book from Sybex by Todd Lamle. That’s one good book for CCNA. For CCNP, well theres only cisco books and labs by cisco academy. Also have the book called “Network Warrior” cause it tells you want CCNA should have taught you but did not. Both tests require hands-on training of course.


#15

Yep, I’ve tried lowering both and setting them both to 1472. Also tried it on just my modem aswell (before bridge was enabled).


#16

This is a wierd problem indeed and most intriguing.
I’m looking around the forums and seeing what people are saying…

One suggestion is to turn off uPNP on your PS3. Have you also tried that?

edit***

Sorry, that was to fix DMZ, and port forwarding.

When the error message pop up? I also bridge the verizon modem/router and just use a cisco 871w soho router.
I tested the internet connection using automatic settings for IP, DNS and MTU and no problems.
I tested the internet connection using manual, static IP, manual DNS, and MTU and no problems.

At this point, I’m stumped.


#17

Hey guys maybe one of you guys can help me out. I dont know anything when it comes to networking and all that jazz.
I have ATT DSL service and i called them today to help me setup my router with their DSL box. He walked me through and had me reset the DSL modem, i assume we bridged it.
-In my router settings i switched to PPPOE and typed in my email and password. After that he said we were done.
So i tried to use the info on the first page except i put PPPOE and put all my info in. Now im having all kinds of trouble. When i test the connection on the ps3 it times out at PSN network or sometimes the internet connection says failed on the test. Also the internet on my comp is acting up. Sometimes cant find the internet. All this started after ATT helped me set things up.
Can someone please give a helping hand. Its driving me crazy. Just wanna play some KOF12 and MVC2(especially since i just dl’ed it)
thanks


#18

How does your setup look like?

Does it look something like this?

Internet through phone line ->ATT MODEM/Router -> All devices connected to ATT modem/router?

Or

Internet through phone line ->ATT MODEM-> Linksys or other router -> All devices connected to router?

Also when you say first page, are you talking about the Router or PS3 network connection settings page?


#19

Its phone line —> ATT modem --> Linksys --> PC/PS3

I meant the first post. I basically did everything you mention in your first post.


#20

Ok, log into the Linksys through the web interface and then tell me the IP address where it says WAN from the status page.

This should tell us if your ATT modem is in bridge mode or not. Sounds like its doing a double NAT (ATT modem also acting as a router so if you’re doing port forwarding from the linksys, the ATT modem/router combo is giving you troubles). Thats just a thought and have been the case in most scenarios where I have helped people in the past.

Forgot to mention - the PPPoE settings are for your internet connection - don’t do it on your PS3, your router will handle that.