How was I supposed to know THAT?! moments in gaming


#1

Today games pretty much hold our hands throughout the game in order to help us complete them. There may be some odd, out of the way hidden things (see: GTA hidden packages), but these usually aren’t required to beat the game. This thread is dedicated to those moments in gaming where you’ve been FUCKING STUCK unable to beat the game because of some weird arbitrary task that you were required to do to beat it.

Here are some of mine in no particular order:

X-Men (Genesis) “Reset the computer”: First off this game wasn’t exactly easy. There’s a part where you finally beat Mojo, and the game tells you to “reset the computer” while a timer ticks down. So many times I sat there hitting buttons trying to do shit and then died when the timer ran out. I can’t remember how many times I got to this part, and couldn’t figure out what to do or turned off the game in frustration before the time I actually just hit reset… IT ACTUALLY WANTED YOU TO RESET THE GENESIS Holy fuck I couldn’t believe that shit at the time.

Damn near anything in Zelda II Adventure of Link or Castlevania II Simon’s Quest: Both of these took me over 8 years to beat. In Zelda I could never figure out how to get the down thrust, but after that it wasn’t so bad… Castlevania on the other hand? Hit this non-descript block with this item to make shit happen. Go to some random ass ledge and kneel to make a tornado appear… THE FUCK?! How the hell was I ever supposed to find that shit?


#2

In the old DOS game Phantasmagoria II: A Puzzle of The Flesh there’s a part near the end where you have to activate a portal. You try everything. EVERYTHING. Every single item in your inventory, all the command prompts and their various combinations…until you realize you have to RIGHT click on it. Every other action in the game used the left mouse button. Maybe this isn’t fair because that’s obviously a bad programming error, but it infuriated me for a good week of my summer back then.

Let me try something a little different with another DOS game: Ripper, a game based on the Jack The Ripper myth but in an FMV game starring Christopher Walken and John Rhys-Davies. No, that was not a typo. One of the puzzles has you looking at a map of the zodiac constellations and you have to arrange a series of pegs to mimic the symbol of your girlfriend’s sign. Jesus. Fucking. Christ.

This was back before game developers held your hand or just banged out Quick Time Events. Plus there was no GameFaqs. Ugh.


#3

Legend of Zela: Link’s Awakening for the Gameboy. In order to get the nightmare key in the Bottle Grotto dungeon a tablet tips that you must defeat the imprisoned Pol’s Voice first and then Stalfos for the last. The problem is, I don’t know what is a Pol’s Voice and a Stalfos (the manual does not have a monster database), and that got me stuck for many days, even accidentally discovering some dungeon-skipping glitches along the way and finished the game using them (remember that the Internet hardly exists during this time). I finally managed to get it by killing the monsters in the correct order by throwing pots at them using the Power Bracelet.

I should have discovered that time that both obtaining the nightmare key and defeating the nightmare itself highlights the weapon/item that you obtain from their respective dungeons.


#4

Dragon Warrior II was a pretty open ended game once you got the ship. If I didn’t read a faq on the game I’d be playing it for months worth of time I would imagine.


#5

There’s this game out there called Milan’s Castle (I think), it’s this old SNES game. I had it on this little bootleg 108 in 1 GBA game, and I could never find out what the hell I was even supposed to do, right from very beginning. Later on I was watching angry nintendo nerd, turns out he did a little section on it. I can’t even remember what the hell it said to do it was that stupid. Even in Nintendo Power’s cheats section they put a little part for it titled “How to get started”.

I can’t remember anything else at the top of my head, but I’m certain there are some others. I’ll be chcking this thread, hopefully it’ll jog my memory.


#6

Dr. Jekyll & Mr. Hyde (NES): How to play the game? Arguably one of the most poorly designed video games ever
BatMan Returns (SNES) How to use the grappling hook
Hydline:(NES) How to save your game
Castlevania 64 (N64): Which order do I get the following items in? Mandragora, explosives
TMNT (NES) 3rd stage in the warehouse with a pizza and an impossible jump over a small gap. You’re actually supposed to walk over it

If you like this kind of stuff,just watch AVGN

http://cinemassacre.com/2007/04/08/full-list-of-avgn-videos/


#7

Whenever the topic of Guide Dang It’s comes up the one that instantly pops to mind are those rotating platfrms in Sonic 4’s Carnival Zone where the only way to make them move is to hit up and down on the D-Pad in time with the motion of the platform moving up and down. Never in a Sonic game had you had to (Or since) had to do this, they don’t mention it in the manual, and nothing in the game hints at you having to do this. The most logical thing to do is to jump up and down on the thing but it will never get it moving enough to get you past the one part that forces you to mess with one. I remember being stuck on that fucking thing for years because of this shit. Its the only one in the game you have t mess with and the door the room shuts as soon as you run making it a dead zone. You cant back track, you cant try to find another room. Just you stuck in a tiny room with the fucking cylinder you can’t figure out how to use.

Trolling man…trolling.


#8

Not quite. The grappling hook sucked, but at least you knew what it was and after some fidgeting you could usually get it to work. What I totally didn’t get in that game, was how to jump down.
I literally tried every button combination, but since the input is so specific, I never got it to work. At least with the grappling hook, you hit select and it comes out, so you know what button to press. When you hit the R trigger there’s no indication that it might be used for jumping down, so unless you know, you’re stuck mashing every button.
The first time you have to jump down a hole is at about 4-5 screens into the game. I didn’t even make it halfway through the first level before returning it to the store. The worst part was…

They didn’t even explain how to do this in the motherfucking manual! I don’t care how to use the useless weapons, like the goo gun or whatever! Tell me how to fucking move around!


#9

In the 90’s PC point and click adventure games like the King’s Quest series were known as “find the pixel” games, this genre takes the cake hands down. They just throw the most obscure and complicated puzzles at you with no hint at all at how to play the game let alone solve them…and I loved them because of and despite that.


#10

I just recently found out the Sega classic Altered Beast for the Genesis had friggin’ cheat codes. You could set your preferred beast for each stage!!! Thought the bear sucked? You could get the Werewolf, Tiger, or Dragon instead for stage 3.

And of coarse— a much needed stage select code. Because those last few stages were an epic pain in the ass, and in serious need to revisiting to memorize how to deal with the enemies.


#11

I was stuck on that one for a good month or so too. But, upon second looking the clue it actually made sense: Imprisoned Pol’s Voice was the Rabbit surrounded by squares, meaning that he couldn’t get out unless you freed him. That was your first hint that you needed to kill him first. Next, Stalfos was a toss up between that bat and the dude. I guess you wouldn’t call a bat “Stalfos” so you can pretty much guess it was the dude firing arrows, and killing him last solved the puzzle.


In the original Mario Bros, castle 7-4 required you to take certain paths in order to reach Koopa. As a kid you were not expected to know where to go, which made this castle very confusing and resulted in many timer deaths.


#12

Didn’t this game have the best glitch ever? Playing with them in other games?


#13

Holy shit THIS, I thought that was just me. I remember when I was little, if I wanted to play through Sonic 3 I would just play up until this level then delete my data and start again. Nearly 8 years later when I decided to play through all the Sonic games via Mega Collection, I figured it out right there.


#14

What made things worse is that some models of the Sega Genesis didn’t have a reset button :frowning:


#15

Push-through-able walls in the original Zelda, the second quest.

I called them this, because it wasn’t like you just walked through them on a whim, but had to actively walk against them like a retard, in order to discover them.

Castlevania 2 had lot of horridly obtuse shit in it. I loved that squatting on the ledge thing. Yes, there was a “hint”. But not really.

The fucking chests in Final Fantasy 12 that you could not open if you wanted to get the best weapon in the end game. There was literally no way - zero, nada, that one would have magically deduced that out of thin “just 'cuz”. Strat guide required.


#16

Terminator 2 Judgement Day SNES - Every time I got up to the Mall stage I could never figure out how to get John Conner to follow me…I only ever rented this a few times so this game went unfinished

Battletoads SNES - On the speeder bike level there was a section of the course where you were not able to fully jump to the next section of land so you would fall into the balls below…game over…then by luck I learnt you just had to mash buttons to rise up out of the pit of balls…smh

Super Metroid - First time playing this game stumped me a lot to the point of having to start a new save file. the first time you meet the Etecoons they teach you how to wall jump but I didn’t really pick up on that too quickly and just quit the game. How was i spose to know you could simply wall jump out of there…it’s not like they mentioned it in the instruction manual

Wonderboy 2 Master System - The final labyrinth was a puzzle maze with a strict timer…goodluck figuring this one out ur first time. I think I only ever made it to the last boss once or twice…only to die very quickly…

fuck that e begging avgn, that dude dies on purpose in his reviews for comedic effect and he hates on bugs bunny crazy castle series which aren’t bad games at all.


#17

Any game that wasn’t made for the retards of today.


#18

Huh? Glitch?


#19

I just thought of one

Final Fantasy X: Lulu’s Venus Sigil: Dodge 200 lightning bolts in Thunder Plains, all in a row, all without saving.


#20

ghostbusters 2 on the C64, the first level i could never figure out how i was supposed to collect the slime at the bottom of the sewers. i pressed every button i could think of and never got the right one. a few times i thought maybe there is no indication to show you collected the slime, and managed to make the agonising trip back to the top, only to find nothing happened. i should look it up and try it again really.

fucking hell this got me for a good while as well. a few times i very nearly managed to get the cylinder right to the bottom by making expertly timed jumps on top of the cylinder to build momentum, but never managed to make the jump off to the side. i couldnt fucking believe it when i found out how to do it. how the fuck that got through testing i dont know.

also Dark souls has given me a few WTF moments particularly with the random false walls.