HRAP 3 Turbo Button

This thing is insanely annoying Comes on at pretty random times then does not shut off unless i power the system off. Why is it there? Can it be easily disabled is there any purpose to its existence at all?

Takes an icepick to turbo button

I have 2 HRAP3 and while I haven’t had any problems I’d be curious to know if there’s any somewhat easy way to disable them, seeing how I never use them.

I have a HRAP 3 AV and have no problem you prolly just got a fucked up PCB or you keep hitting it without realizing it took me awhile to figure out how it works. make sure the LIGHT is never on. also that could be whats the problem it could be working but your led is fucked up in some way.

It sure is annoying and serves no function.

Not to hijack your thread Arxinal, but I was wondering if it is normal for the HRAP3 to continuously register button presses when the you have a button held down (eg. Negative edge)? this only happens when it’s plugged to my laptop and it’s irritating.

You could open it up and disconnect it, no? :slight_smile:

It should negative edge if the game permits, but that should only work for specials/supers. Normals should not come out when negative edging.

When I negative edge the button pressed keeps being registered as a new input, as in while holding jab the character will repeatedly throw out jabs instead of just one.

Is there some check box or setting I have to turn off/on in MAME?

if you want to disable the turbo button permanently i think the easiest way would be to scrape away the contact or sever the lines that leads to the contact on the pcb.

check the pics to see what you are working with

I gotta side with you man. A friend of mine and I were playing when that exact instance happened and powering down was the only way to fix it.

Seems like opening up and disconnecting might be the best solution…meh.

how do you even turn off turbo?

this button is extremely annoying, but it’d be nice to have for shooters … maybe

Read the back of the hrap3 box it has instructions. It appears most of you are unable to or too lazy, but to turn it off you hold turbo + select to turn off all turbos. Geez … you guys want the next test questions handed to you as well ?

or maybe not everyone sits around reading joystick boxes?

try not be such an angsty internet douche, it’s overdone, particularly on this website

oh, and thanks

I don’t have angst, and you don’t have to sit around reading boxes. In fact there is a very nice large picture.