HRAP EX Suddenly stopped working (Win10)


#1

I’ve been using the HRAP EX for about a year now on my PC and today it stopped working. Every thread I’ve found on the issues claims it’s a driver issue, but HRAP.EX isn’t in my device manager. There aren’t any errors, or changes at all, in device manager when I plug the stick in but the 360 logo is flashing all 4 lights in its ring.
This happened when I tried to plug it into my brother’s PC two weeks ago (I’ve since used the stick with my pc) but his device manager showed the stick as a driver failed xbox 360 controller that refused to update. Both of us use Windows 10.


#2

Does it work on other computers or a 360 console? Because it might just be the USB cable dying. Test with a multimeter and repair where necessary.


#3

My PC is the only one available to me, but I assume it’s not the cable. When I had this issue at my brother’s house I went home and plugged the stick in to find it working just fine.

After typing that out I found my stick not turning on at all. So while the USB was still plugged into the computer I separated the detachable cable, and after cleaning it, then reattached it to find it working correctly again. Not sure if it was loose this entire time, or the cleaning fixed it but it is now working as before. I still would be interested to know what was causing the issue with my brother’s PC as it was detecting it, but as a 360 peripheral instead of HRAP.EX. Yet a 360 controller that was also plugged in (shown to be using the same driver) was working just fine.


#4

Isn’t it pretty clear that your cable or the connection is busted?
Why did it work then and not now? Reasons. That’s how busted cables operate. It’s either a bad cable (it happens), or a short at the end where it plugs into the whatever connector it goes in. You can try contacting Hori for a new cable or check to see what kind of connector it uses at the detachable end, then see if you can find another cable.

It detected it as a 360 peripheral because all 360 controllers use the underlying native Microsoft 360 HID driver, even if the directinput driver calls the controller something else. My madcatz X360 TE stick is called “Madcatz Fightstick Neo (arcade stick)” in game controllers/joy.cpl, and shows up as a 10 button device without an analog axis for the joystick, and with direct buttons for RT and LT. But check in device properties and it’s using the Microsoft xbox 360 HID driver. And in Joytokey, if you enable all axes and buttons, you can see the “missing” analog axis for the joystick (if on LS) and the analog triggers that are hidden from directinput, but show up under xinput.

That’s just how it works.