HRAP1: Stick stuck down while in neutral position (solved)


#1

Hi SRK. sorry if this problem has been posted… search function, and skimming a few pages back yield no results, so I figured I would post my problem.

A few weeks ago I noticed the stick would make a squeaking noise when it was moved into down, and up position. This didn’t bother me, and I figured it was just natural degradation as I’ve had the stick since January.

But when I went to training mode today(first time stick has been used in ~2 weeks), at the first menu, the stick was automatically selecting only down, despite being in the neutral position. When I pressed up, it would just stop. So I made it to training mode for further inspection, and I found out that: b, db, d, df, f are all unresponsive. uf, walks forward, ub does the the same respectively.

**My question: **Why did this happen, and how can I fix this?

Anyways, I was planning on buying a new stick once it started squeaking. I am most likely going to regardless, but I figured I will give fixing this a shot so that if it ever happens to me (or any SRKers) again, I will be prepared to fix it.

I’m going to open it up now, and possibly make things worse. :rofl:
If I find any solution I will promptly edit my post.

Thanks for your time and advice in advance.
**

[edit]**Okay, so I opened it up, did some completely random things to it, and to my surprise it just worked…

The first thing I did was clean the bottom of the shaft(:confused:) with a little bit of alcohol on a qtip… this fixed the squeak right away. I wasn’t trying this to fix the stick, but maybe the gunk buildup is what caused it… dunno.

Since I don’t know why it happened, or how I fixed it, I guess this thread is pointless. :sweat:
Maybe if you’ve had experience with this and found a solution, post up… but this OP is satisfied.


#2

well if you’re using the stick very frequently, and it’s starting to act up, you could replace the sanwa (model JLF-8P-TY-SK) stick, www.akihabarashop.com is a good source.