HRAP2: R2 is stuck


#1

I’m hoping somebody here has had this problem before: I got this HRAP2 brand-new on monday. It’s been perfectly fine until about 20 minutes ago: it’s constantly registering a press of R2. I don’t have the turbo switch on, and setting it to “on” makes no difference. I’ve tried starting the PS2 with the turbo switch on and off, but it doesn’t help. The thing was working perfectly fine a few hours ago, and it has done nothing but sit on the floor since then.

So first of all, any suggestions would be welcome.

Secondly, I was planning on ordering some sanwa buttons for it next week. When I finally take the thing apart, is there anything I should look for? Should I disconnect the turbo switches just to be safe? Or does it just sound like a bad button?

Thanks in advance…


#2

That sux. Right out of the box. Hopefully someone can help you. I know I’d be pissed.


#3

blech, I think I’m going to try and return it…


#4

its a CONSTANT press not a rapid pressing?
hmm looks like the ground is bridging with the r2 some how
there are a few threads in here on how to check what the problem is
take a look at those and try to figure out the problem

for the sanwa buttons make sure you get snap ins or you’ll run into a few problems with screw ins.

here
http://forums.shoryuken.com/showpost.php?p=4013204&postcount=16


#5

I think it would technically be a rapid pressing. For instance, when I fire up 3S and go into a mode, it automagically selects Alex and SAI, then when the game starts he stands there hk’ing like there’s no tomorrow.


#6

EDIT: This info is for a stuck button, not a rapid fire button! Check the bottom of this post.

There’s no way to disconnect the turbo switches, so scratch that. Closest you could do is remove the slider pieces so it always thinks the switches are down, but that’s not your problem.

You are gonna have to crack it open though. Somehow, the two wires for the R2 button are electrically connected. I figure there are three things you want to check, all require opening it up.

  1. Make sure the QD’s on the button arent touching. If for some damn reason the QDs on that button got bent and are touching, this would cause this. If they look like they’re touching, bend them so they arent and test it out.
  2. Microswitch in the button is dead or jammed. Pull off the two disconnects from the button, and wrap them lightly in electrical tape so they dont touch nothing else, especially each other! Plug the HRAP2 in, push the slider switch for the R2 button to half way (‘Turbo when pressed’) and see if it thinks R2 is repeatedly pressed. If it is showing as pressed, go to #3. If not, the problem is the button and can be replaced easily; just laugh and tell yourself the sanwa button mod you wanted to do is coming a little earlier. While you’re waiting, you can remove and disassemble that one button. If you spilled Coke on it and it got sticky, you could clean it and have a working button till the sanwas get in.
  3. Button short on the PCB. You may want to get ahold of Hori and see if they’ll swap you out unless you’re comfortable with a soldering iron. Even then, it’d prolly be easiest. If you’re gdlk with an iron, check for shorts on the PCB itself near where the two wires for that button plug in.

Oh, shit. Rapid firing the button? That’s different. Somethings not right with the turbo switches then. Take it apart and look for something shorting those two points on the turbo slider switch.


#7

if you have gg or virtual fighter, their command screen in training is way more detailed vf shows you when the button is pressed AND released and i think gg does the same.
regardless the link i gave you should help immensely


#8

So do you guys think I’m better off opening it up? I contacted the eBay seller about a return but they’re closed for the day. Not sure I would want to return it anyway as I would end up $30 in the hole for the shipping charges.

I would hate to open it and not be able to get it back together properly, and lose any chance of a refund. I haven’t soldered in years so I wouldn’t trust myself on anything halfway delicate.

I will check the GG training mode and see if that gets me any more info.

update: in GG i got some confirmation: going to character select, the EX option keeps highlighting off and on, so it’s definitely rapid-pressing.


#9

Its acting like the turbo switch for R2 is pressed all of the way up, or its . Something is shorting those two points. If it were me, I’d have that SOB open. Even if I couldnt find the short, the turbo line for R2 can be cut if your careful. But this is your stick and your call, and you have a valid reason for wanting to return it.


#10

Well I opened it up and didn’t see anything obvious. The bottom of the turbo PCB looks fine, and the wires aren’t shorted anywhere. There’s plenty of space between the QD’s on the buttons themselves. I didn’t separate the switch PCB from the plastic though.

How would I go about cutting the turbo wire?

I emailed the seller about a return but won’t hear back until tomorrow as they are closed.


#11

the pcb is held to the white plastic with two bendable tabs on one side, and a unmovable tab on the other. Bend the tabs so that side pops out and remove. Be careful; those red slider switches arent attached to anything and will fall out and get lost if you’re not careful.

You got a multimeter? Theres an easy way to check if the points are shorted. The turbo switch on the board looks like this:
[][]
[][]
[]

The left hand side is one big rectangle. If theres a connection between the left hand rectangle and the upper right square for the R2, that would cause whats happenning. Big know how fickle electronics can be, just opening up, removing the switches, and replacing them just may fix whats happening. Its weird how disassembling and reassembling often fixes things.


#12

Unfortunately I don’t have a multimeter. I pried the whole thing apart and I didn’t see anything that looked like it could be a short. I tried using it without the switch assembly and it was still shorting. I even tried blasting the whole pcb with compressed air in case there was a metal flake or something causing the short but it didn’t help. I would bet at this point there’s short on the pcb that’s too small to see.

At this point I don’t think any sort of button replacement will help, it’s definitely an issue in the turbo pcb. Hopefully I’ll be able to return the thing.


#13

Well, just as an update, I got in touch with the place I got it from and am going to get a full refund. They don’t have any other HRAP2’s in stock, so now I am faced with a new decision:

Find another one, or spring for a custom build…


#14

Try here, I think he still has some.
http://forums.shoryuken.com/showthread.php?t=131235


#15

Yeah I saw, the issue is the stick + sanwa buttons and a new gate puts me in the price range for a nice custom. Not quite sure what I’m going to do yet.


#16

what are you going to do with your hrap2 then?


#17

I sent it back to the seller for a refund yesterday. Guy said he’d never heard of one with a manufacturing defect before. I got it from an ebay store for a little under $100 after shipping.


#18

I say keep it untill you get your Sanwa parts… In the mean time I’m sure you can find someone who would wire up a PS PCB for you…

Edit: Oh well…