Hrap3 Problem


#1

Hi, i’m new to both the srk forums and home arcade sticks.

I was wondering if you guys could help me with my problem. and yes i’ve googgled and looked through this site,in hopes of troubleshooting but with no success.

I recently got a hold of a hrap3, i’ve been satisfied with it and plan to add plate art and replace the buttons. Ok here’s my problem, after less than a month of use my pc and ps3 stopped recognizing the stick, most likely do to a usb malfunction. To be exact the turbo light flickers and get the usb device malfunction message on windows. I’ve tried a usb extension, it solved the problem for a little while, but now it stopped working again.

I’d like to know if i can easily replace the usb cord attachment from the inside, do i have to completely remove it or only just a portion, where can i buy a new one that will work with the hrap3 if there are any?

Really don’t want to give up on the investment that i made on the stick, especially only after such a short time. Any help i can get would be most appreciated.

Thank you very much, and if this is the wrong place to post, then can i please be directed to the right location.


#2

Looking deeper into the issue, It could either be two things for me.

  1. it would seem that my usb wire was crushed by default, the first time i opened it i noticed that the wire was being pressed on by a little tab. I think the wire maybe shorted close to the pcb slot. I could replace it if i knew where to buy a usb joystick cable, basically usb type a to 5 pin, or cut the wire and replace it with a new one.

2.It could just be the usb tip, this problem could be solved in a similar fashion.

If it is reason one, then i’m very disappointed in the packaging, they could have at least use tape to hold the usb cord like they did the wire.

Again any help i can get would be appreciated.

Also thanks for the reply walryus, my problem is that it wont read on the ps3 either, one of the other reasons i think its a cable short is because if i move the cable around while its plugged in, it makes the stick work for a few seconds.


#3

If you’re handy with a soldering iron, all you really need to do is replace it with a regular USB cable/extension cable. Just cut off the end you don’t need, then mix and match color of wires to the existing order


#4

Hey, I noticed your post on the official HRAP Faq and you posted a pic that was a usb to usb header cable.

http://www.amazon.com/Cables-Go-Internal-Motherboard-Adapter/dp/B0000511EZ/ref=sr_1_3?ie=UTF8&s=electronics&qid=1248232837&sr=1-3

Check that link out, its a dual usb port for a desktop which has 2 usb femal ports with the other ends being the 5pin header that connects to the motherboard. You can get that, disconnect one of the usb females so you can have that in the stick and then get a male to male cable to plug into that and the PS3. Or if you have an old desktop lying around, usually the front USB ports connect to the motherboard this way, and you could just take it out of that.


#5

Hi incognito. I actually have the same problem myself, except my computer doesn’t even read the “usb malfunction” error. It doesn’t give me any kind of message at all.

I’ve tried jiggling the wire, opening it up and reconnecting the 5pin connector, etc. I know the buttons and the pcb are still working though because when I plug the stick in the turbo light flickers for me as well and all the buttons register.

Have you found a solution to this? And perhaps one that isn’t soldering reliant? I absolutely do not know how to solder =S.