Huge problem with TE PCB


#1

When I was going along with removing solder from the TE PCB, the little copper ring that surrounded the copper hole, on the 5V (VCC) from the USB cord, is gone. On both sides.

I don’t know much to be saying this, but does this mean that i just completely ruined my board? I mean isnt that ring to make a contact with the circuit?

Quick help please, im freakin out.

http://img3.imageshack.us/img3/6105/img20100714205735.jpg

EDIT: I attempted to solder it and it doesnt stick to the board, it just sticks to the wire.

Should i throw it out of the window now or later?


#2

accidental double


#3

Scrape out some of the board (I use an exacto knife), and search for some tiny metal contacts nearby. Bridge these two together and use it as a solder point. Worth a shot.


#4

turn over the board and see what road it leads to. You probably have to do what ^ this guy said.


#5

I tried doing what you said, and as soon as it stuck it ripped off.

Is there any chance I can solder it directly to the component thats right next to it?

The solid red is where the strip was before it was torn off, and the component is in the box.

http://img203.imageshack.us/img203/6105/img20100714205735.jpg


#6

See the white rectangle on the bottom? The one with the wiring harness leading to the turbo panel. The sixth (as viewed from the picture’s orientation) solder point is an alternate 5v spot.

Be careful with that soldering iron, bro!


#7

Yes, you can solder to Component B1.
Solder to the side closest to the original hole for +5V.

Other people have done it.
Even I had done it.


#8

Thanks guys, i finally finished it up, and tested it on both consoles at first, they both worked fine. I ended up doing what you guys said and soldering it to the components directly.

Then I decided while im at it, I would take the default art sticker that came with it, removing all of the buttons and such.

Then I placed it back together. So I thought I would test it again for good measure.

PS3 works ok, i think the L buttons are a bit messed up though.

I tested it in hdremix, and theres a problem with diagnal jumping.

Sometimes when I went to diagnal jump, it would just do a neutral jump. I kept doing it over and over again and I noticed it mostly only did it when I went from neutral position to diagnal.

But when I go from up to diagnal, it wouldnt work sometimes.

Then I tried it on my xbox again. The joystick didnt work.

I checked the cable from the joystick to the madcatz pcb, and its secure. Im not sure whats wrong?

Any ideas?


#9

What board are you using for PS3?


#10

im using the chimp

not sure what to try now, should i resolder the joints?

tl;dr

joystick doesnt work on xbox, works on ps3


#11

it works now, i think i had it set to RS, which is why it wasnt working. grats on me being retarded and reassembling it all for no reason.


#12

I noticed a massive influx of TE PCB complaints here lately. Are the PCBs prone to breaking?


#13

Even read the rest of the thread? It didn’t really break on its own