I can't step right. (new madcatz TE round2 fightstick problem)


#1

Hi Shoryuken,

I did a bit of a search going back several pages of threads, and found a few button issues however none quite the same as the stick issue I seem to have.

I purchased 2 x Madcatz TE roud 2 fightsticks, one of them works perfectly, the other seems to be fine apart from moving to the right does not work, that input seems to be broken.

Just wondering what the best course of action to take would be from some of the more experienced stick using people, as I hear they are not too complicated to fix/repair, but if I had to send it off (being from Australia), it will take quite some time.

I plan on calling madcatz, I suspect either the stick base has a bad connection or wires / pcb, and can use the other stick to work out what part is faulty, however not sure if this will be wise till i have approval.

Anyone have any idea’s suggestions or know anything about the process of fixing these? I don’t think I can find documented anywhere that just one direction does not work. (up/down/left all work).

any input would be much appreciated,

Regards,

Nathan.


#2

If you know anybody with a multimeter, borrow it. Multimeters are extremely useful for this sort of problem, when you know there is a connection problem but can’t really tell where.

Without it… open up the broken TE (from the top, so as to not void your warranty). Find the 5-pin connector on the broken TE (looks like this), disconnect it then reconnect it. Do the same to the other end of the connector, where it connects to the PCB. (It’s really unlikely, but sometimes they come loose) See if it works.

Still no good? Open up the working TE and disconnect the 5-pin connector from both TE’s sticks. Connect the broken TE’s connector to the working TE’s stick, and move the stick to see if it works.

If it does work, the problem is your JLF stick. You simply need to buy a new microswitch PCB assembly from lizardlick (looks like this) and swap it with your broken one. If you know how to solder, you can buy just one microswitch for 1/4th of the price instead.

If it doesn’t work, the problem is your PCB. Take a picture of it and maybe someone else can help you, though I would just ship it off to Madcatz.


#3

Thanks heaps for the information, appreciate it.

Shall give that a try tommorow when stores are open to get the allen key, I think I may grab a multimeter too, handy for many things I guess.


#4

You sure the switch is on DP? Make sure it’s not on RS or LS


#5

Yeah, it is on DP, have tried LS and RS however, to no avail.

Cheers for the reply.


#6

I’ve got a similar problem. My stick has a deadspot on the ‘down’ microswitch. It registers immediately after the click, pushing farther makes it stop registering, and then pushing it all the way makes it register again. If either the left or right microswitches are active, though, there’s no deadspot.

Everything joystick-related is nice and snug, there’s just that one inexplicable deadspot. I’ll probably fix it with a couple layers of scotch tape or something, but it would be nice to know what exactly is the cause. Any ideas?


#7

If you have a multimeter (and are willing to break the warranty), open her up, and check for continuity for the right most microswitch by testing between the two exposed metal terminals when active. If there’s no continuity when it is activated, you likely have a microswitch problem. If there is continuity, then pull out the wiring harness, and hold one probe of the multimeter to the top most pin, and the second to top pin of the metal probes where the wiring harness once was. If there’s no continuity between these two points when the right direction is activated, then it’s a PCB problem.

If there’s continuity between both of these points, there may be a poor connection between the wiring harness and madcatz PCB. Hopefully it isn’t this, though.

If your still under warranty, I’d ship it off to madcatz and save yourself some worries.

@ Deaflier? since you’ve already cracked her open, you could order a replacement PCB with microswitches?Sanwa TP-MA, or a replacement microswitch Sanwa MS-0-2P (requires soldering) The former is easier and costs a lot more, but you can just screw in the replacement without soldering. Either way, you’re looking at about $13 for the full PCB or $3 for the switch. And if you don’t have any soldering equipment, an iron, solder, and a desoldering device will run you about the same as getting the full PCB.


#8

Thanks, Nerrage. From what I’ve seen so far online, it looks like my best bet is to just completely replace the stick and all eight buttons. That’s also the feel I’m getting from using the thing, because while the stick fixes itself on and off, the buttons are only responsive if the upper-right section of them is pressed.

I think it’s just shitty parts; to make things worse, the warranty was actually already void when I bought it. I think my problems may have something to do with the fact that I got it for less than half of what the Capcom booth was selling it for, and got it from the Madcatz booth.

Madcatz isn’t listed in the official program (San Diego Comic Con 2010) as having a booth.