Injustice arcade stick problem...again

i asked here a few weeks back, but now its a different button and somethin a little different. the X button sometimes just doesnt register. hitting it hard fixed it for a few days, but today, i was doin some kof trials, and i kept hittin the button and nothin happened. even mashin it hard didnt fix it, but it somehow fixed itself again. whats wrong with it this time? i opened it up yesterday, cleaned it, made sure all the plugs where in, and its still doin this. it doesnt make a squeaking noise this time though, and when it does work, its as sensitive as the other buttons.

Could be the switch inside the button

ill check it out right now, thanks

the switch is the little white square piece, right? if so, i cleaned it yesterday and just now, and it seems fine when i press it down.

edit
ok, so i just found out that when i hit the bottom left of the button, thats when it almost never responds. when i hit the top-left, top-right, or bottom-right, it is fine. what can i do to fix this?

edit again
aaaagh, this stupid button didnt respond on either side this time. i have no idea wtf anymore, i dont wanna go back to usin a controller :frowning:

edit a third time
i noticed that the little green circle thing with the LED inside the button was out of place. i pushed it down back into place, but the button is still bein a bitch. everything looks fine know, what the hell else is there that can even be fixed?!

Just try replacing the button. If that works it may be that the previous button had a bad switch. Hitting and cleaning it is not going to help much if its a faulty switch.

The following link takes you to a thread where the stick has been moded

You should either replace the button or replace the microswitch, Sanwa-68 switches will work in the Qanba button.

fuck, i cant. if this was my arcade stick i would try replacin the button, but since this is my brothers, he will know i messed with it. fuck this stick, im done with it, back to controller.

is there a way to test if its the switch? i stopped playin with it since my last post, just tried again today and the buttons still messed up.

edit
ok, its definately the switch. i tried playing like this
http://sdrv.ms/1daQZsv
and it wasnt responding every single time.

this is the one to buy, right? just wanna double check


or should i get this one?

You want the Sw-68 switch.

That 24mm button will be too small

ok good, i ordered the switch before you posted. i still want the led light.

edit
completely forgot to ask. what if putting a new microswitch doesnt fix it? what would be the problem then? and thanks for all the help in both threads.