Internet connection keeps dropping out


#1

I have a pc with windows 7 and I don’t know if that has anything to do with it,my connection keeps dropping.I hook it to my wii and the browser and everything runs fine,how do I fix this issue?


#2

What kind of firewall are you using?

Is it after you let your computer idle for a while that it drops out, or just suddenly while you’re still using it?

We need more info than you gave us. We can clearly tell that it’s the computer, since everything else connected to the internet works fine while the computer screws up but we need more info about what security software you have set up on your computer.


#3

it’s avg and it happens also when I’m using it.
edit: If I leave the computer for any extended time it goes out also,so both ways.


#4

We will need more information on what you means by “my connection keeps dropping”.

Does that means the internet stop working entirely on everything, including browser going to website? And how do you fix it? restarting computer?

Does that means only dropping your current game session, like being kicked from a match? and you have to find another match?

Please be more specific if you can.


#5

I don’t game,I can’t browse the internet,I can’t sign into aim,it’s zero activity.


#6

You didn’t tell me how you get it back. I assume it is a reboot or something… or simply wait and it come back later? Whichever, since your Wii still work, it might be something else. I believe AIM use IP address to connect. but to confirm whether it is a DNS or an actual internet outage, try the following:

  1. Try go to Google with just typing 209.85.157.10 in browser of your choice and see if it still work for you now. You might need to add http:// in the front depends on browser. This is the IP address of google.com. It should work just like going to Google. If it doesn’t work for you, something is wrong with your computer. Ask again here.

  2. Keep this ip address 209.85.157.10. Go there again when you have an outage again.

  3. If it still work, that means your ISP have crappy DNS, or your computer are DNS poisoned. Follow the instruction here How to Flush DNS and try www.google.com again, if it start working after you flush your DNS, your computer DNS is the issue. If not, your ISP DNS is the issue.
    3.a) If it works after you flush. Well, that should fix your problem for good, if it keep repeating still, ask again here.
    3.b) If it doesn’t work after you flush. Get a new DNS. either Google Public DNS or OpenDNS | Internet Navigation And Security should be fine. That should fix your issue completely.

  4. If it still do not work. Your internet connection is probably completely lost. Go to DOS Prompt and do “ping google.com” and “ping 209.85.157.104”.
    4.a) if ping yield no result at all, your internet is dead entirely on this computer. Ask again here.
    4.b) if ping yield some result. Then I don’t know what the problem might be, it could be virus, ask again here.

Tell us exactly which steps you stops at if you ask again. Good luck.


#7

another option is to call your provider and run a test to see if your connection is stable.


#8

I disagree, since the Wii works fine. it is likely that the connection is fine. ISP level support are likely to just give him the “Reboot system, reboot router, reboot everything” routine and never fixes the problem properly.


#9

Just the thought about it. thats all.


#10

that google thing won’t load but I did the dns flush and it seems to be working,I’ll keep an eye on it and if it happens again I’ll try the google dns thing.


#11

If the DNS flush fixes it, it should remain fix. unless something is wrong with your computer OS. Good luck.


#12

ok,It did it again,what would the os problem be? and how would I fix that?
edit:it does it a lot more when I’m away from the computer for long periods of time and I have to unplug the modem and plug it back in for it to work again.


#13

Firstly. Do you use wireless connection or wired?

If it does it a lot, then the problem could be complicated. I suggest use one of those DNS service I linked to make sure it is not your DNS server being stupid.


#14

By any chance, is your system going into “hibernation” or “sleep modes” when you are away for these extended periods? Are you having to input a password on resume?


#15

I put my pc to sleep when I leave,and it has a screen saver after there’s no activity for 15mins.
when I get back on it after it’s out of the sleep mode there is no internet detection,and then I unplug the ethernet cord out of the modem then plug it back in and after like 15 seconds it works fine again.


#16

Windows Vista and 7 has advanced power-saving features. Mostly geared towards increasing the battery life of mobile devices. Easy solution is to not put your system in “sleep mode” when you are away. Sleep mode, by default, reduces/cuts the power to your network card. You could go into the settings of the card/card driver and set it to not cut the powersupply, when the system is in standby, but usually this is a headache in itself. And it sort of sounds like your exsisting NIC drivers do not handle the system resume features very well anyway. For my notebook, I simply modified the advanced features of one of the exsisting powerplans to suit my needs. Turn-off the display, use a screensaver, reduce the power to the CPU and prompt for a password on resume… but there is really no need, IMO, to put a desktop into full sleepmode unless you are in an unprotected environment. Modern powersupply units (the decent ones) have power-saving features built-in anyway when your system is at “idle”.

EDIT:

Something else you could try… go into your Device Manager. You can do this by Clicking “Computer” and selecting the “System Properties” button. In the left column, select “Device Manager”. Select your device under “Network Adapters”. Right-click your device and select “Properties”. Go to the “Power Management” tab and uncheck all boxes. Apply and exit.


#17

reduce the power to the CPU?
I have no idea how to do that


#18

Edited previous post with suggestion…


#19

I did that before you suggested it,it still went out,I’ll just leave it on and cut off the monitor like you suggested before.


#20

ok,I’ve left the pc on and stopped putting it in sleep mode,but it still drops the connection when the computer goes idle.:tdown: