Is my stick screwed?


#1

So I was letting my brother use my stick, and he doesn’t really know what the heck he’s doing but I watched him and other than maybe being a bit hard on it (not that hard) he puts it down. When I picked it up to play, the stick wasn’t registering any movement at all. The buttons still work fine, but up down left right don’t move anything. I tried turning it off and plugging and unplugging it, but nothing. Anyone have any kind of suggestion. I’ve replaced the stick with a Sanwa stick as well as the buttons if that makes any kind of difference and this is the first and only problem I’ve run into.


#2

Probably the wire harness came out. If you did a search you probably would have found ur answer sooner. Now if you’ve checked the harness and that isn’t the issue, then I cannot help.


#3

Maybe open it up and see if the connector that plugs into the stick came loose or something. Just a suggestion


#4

I just opened it up and saw the connector was a little loose. About to go test it out now.


#5

That worked. Sorry for the thread.


#6

Grab a glue gun and put a dab of it between the two plastic pieces that hold the connector to the TP-MA and it won’t move at all.