Issue with brand new TE2+ controller


I just bought a brand new MadCatz TE2+ fightstick two weeks ago.

I play F.A.N.G and my Senpukuga / coward crouch (P+P+P) is only working about half the time (I just tried it 20 times in a row and it only came out 11 times; the other nine times I got either cr. LP, cr. MP, or cr. HP).

But F.A.N.G’s V-Reversal (back+PPP) is working flawlessly (just did it 30/30 times in training… no failures).

I did not have this issue at all for the past five months with my PS3 TE stick connected as a legacy controller.

I even tried switching all the button inputs over one to the right (so triangle became LP instead of square, etc.)… and the issue remained.

Everything is pointing to operator error here, I admit. But if I plug my PS3 TE stick in, the problem goes away completely. And it’s a little odd that I have no issue at all with the V-REVERSAL on the TE2+ despite it being basically the same exact input as the coward crouch.

I’m stumped. And it’s frustrating because I’ve gotten punished online many times for throwing a cr. HP when I meant to do a Senpukuga.

I’m just wondering if anyone else is having this sort of issue with a TE2+ stick, or if anyone has any advice for me?

Help regarding button input issues with TE2+ on Tekken Tag 2, PS3

Sounds like a difference in button latency.
Is this on a playstation 4 or on PC with some sort of Xinput /DLL driver?
Different PCB’s may have different threshold for button response and latency. I don’t really know much about this, but in the old days, this was a huge problem for PC players trying to play Zangief, for example: PPP and KKK not registering when pressed at the same time. Windows 7 seems to have solved this problem as now you can get PPP/KKK to register even with USB keyboards with N key rollover.

However, for controller based stuff like this, the only thing I do know is that having easier registration of PPP/KKK can affect input lag in some way. I believe computer mice have something similar to “prevent” accidental double clicking. The terms are “Debouncing” and “Click latency.” Click latency and debouncing is a rather hot topic in the mouse thread on the new 3360 mouse sensors (which you can easily read up on yourself). You’re on your own with researching those terms, though.

But anything affecting buttons on controllers may also affect joystick directional input lag as well, as there “should” be no difference between a direction and a button press, but you never know…

Do you notice any faster response from your TE2+ vs your PS3 TE stick?


It’s hard to tell, but I think it might be a bit faster. Maybe a frame or two, but I could be wrong. I feel there is a difference, though.

Playing on PS4, btw.


You mean that the stick you are having problems pressing PPP on (the TE2+) is (up to) a frame faster, or slightly more responsive than the TE legacy stick?
There was some talk somewhere about legacy controllers having “lower” input lag than native PS4 controllers, or maybe I have it backwards; I don’t remember atm if it was lower or higher.


I think it might be more responsive. Again, it’s hard to tell. But that first day I had it, things felt a little off… my combos weren’t coming out quite right and I felt like I had to sort of rush my inputs more than I’d been used to in order for them to come out.


Same issue I’m having with my TE2+ in Tekken. 1+2 inputs are not consistent at all, but are consistent on my PS3 stick


I AM HAVING THE SAME DAMN PROBLEM!!! have been using stick all my life, this is my 4th Mad Catz stick, have been using TE1 sticks, the last one prior to my current TE2+ was the Soul Calibur 5 mad catz stick, worked flawlessly on PS3, playing Tekken Tag 2, over 30,000 matches online, never ever ever had an issue with the buttons, used the same buttons since day one, never had to change it out, and i’ve never had issues with multiple button inputs, but ever since i switched to the TE2+, commands like 1+2, 1+3+4 and etc, any inputs that involves more than 1 button pressed at the time, which is MANY commands in tekken, they would come out for example, 1+3+4 input would come out as a 3+4 input, even though im pressing 1+3+4 at the SAME time, its not my fault because those inputs i would never make a mistake on, it’s automatic in my muscle memory. This would happen maybe 15% of the time or so, it would either come out as a 3+4 OR it would come out as 1,4,3 as if i pressed them one by one in a sequence, trying to figure out just wtf is causing this problem :frowning:


If it unbearable, and is not an execution or display issue, then THIS (or another stick) is your next step.


You guys are ignoring the fact that you’re using a different stick. The way your hands are positioned in relation the buttons, etc all changes with a new stick with a new case, etc. I would chalk this up to operator error. Especially since the other similar move is coming out fine. Think about that for a sec. If a different move with a similar button combination is coming out, but the other move isn’t, do you think the PCB is choosing to ignore that one move over the other. It’s YOU. You need to get used to the controller and use it more and I’m sure you’ll start landing that move more often. Go into training mode and train it. This is why you should get a stick and stay with that stick mainly. Just a difference in the case and where your arms/fingers rest can affect your muscle memory and execution. When I switched from my TE2+ Hitbox to my Jasen’s Customs Panzer Hitbox I had a similar issue. Try training for a bit first before you look at hardware defects.


still getting the same problem, just installed Brooks UFB in my TE2+, still getting button issues when it’s a 2 or 3 and even 4 button inputs in Tekken, i do 1+2 input, it comes out as just 1 or 1,2 in sequence even though im pressing BOTH buttons at the SAME TIME, happening maybe 30% of the time, so just WTF is going on??? I’ve tried my old PS3 Mad Catz Soul Calibur 5 stick, and what do you know, ABSOLUTELY zero problems when it comes to button inputs when it comes to multiple button commands…man its getting frustrating…the only reason i don’t want to use the old ps3 stick is that i can’t control anything in PS home page or share buttons, can’t even turn off the system via PS button…I really believed the Brooks UFB would take care of this problem but nothing has changed from the stock TE2+ PCB…i thought Brooks UFB is supposed to be even faster than the TE2+ pcb?


There alot to take in factor of, including how did you do that wiring for that stick.


Right now the only constant in the reports of this issue is the te2+ case and turbo panel. Even with a ufb installed inputs are inaccurate. We know the te2+ has issues with the diodes on the pcb and turbo panel. Just to rule everything out could you disconnect the turbopanel from the ezmod and see if theres any change?


nah dubon, it’s NOT only native to Te2+, ive experienced in Te2 Chunli, Razer Panthera, and i even went through 3 exchanges with TE2+ year the past year with Amazon thinking it’s a hardware problem, ALL had the same problem


Ok. It must be on The ps4’s end then. I wonder if it happens in ps4 mode on pc.


EDIT: Sorry wrong topic


just to answer your question Darksakul, i even bought a professionally modded TE2+ brand new already installed UFB with gummod EZPZ, it still had the same problem, 1+2 coming out as just 1, and so on. One way i can test is it either by doing the taunt dash with bryan In tekken 7 which is FF, 1+3+4, f, 1+3+4, F, 1+3+4, and so on, i can do this easily since ive been doing it almost a decade so if there is a button issue, then a 3+4 would come on on the TE2+, i also can tell by pressing ALL 4 buttons at the same time with 4 of my fingers, i just put each finger on each buttons, then press all 4 at the same time repeatedly, and see if the Ki charge in tekken come out or doesn’t come out, ki charge happens in tekken when you press all 4 buttons at the same time. On my ps3 stick in Tekken 7, it doesnt give me any issues, i never drop the 4 button inputs, but on the TE2+ and ALL the ps4 sticks, i get it. So i dont know just wtf is wrong with the game or hardware compatibility.


Try the same thing on the PC, open joy.cpl and test your sticks input properties.


dude its not a problem when i test them, you know Tekken 7 even has the button test in the controls option, when i press ALL 3 buttons or even all 4 buttons together repeatedly, it shows up just fine as being working, its in the game when i try it even offline, it starts having this problem


anyone with a solution? i dont understand how millions of tekken players, say there are couple hundred thousand STICK users playing Tekken 7 around the world right now, do not experience this, or are they just assuming its the input lag native to the game? because i dont experience this problem using my PS3 stick, im still currently using my PS3 stick for now until i can figure out this problem but i dont like to use the ps3 stick since i cant do any of the options and controls in PS home page and cant send messages, or share, etc with the PS3 stick, can’t even do the analog controls in the customization since it doesnt support those controls.


dude i told you, ive used MANY STICKS throughout the years playing tekken, and sure a brand new stick with different design, layout and height and different sized palm rest area will play a small factor but i get used to a new stick within couple days, its nothing new dude, ive gone through like 4-5 different sticks dating back to Tekken 6 days, so i know how to adjust and i never had this problem, thats like saying i can’t all of sudden don’t know how to steer, brake, and accelerate just because im driving a different car…that concept doesn’t work in arcade sticks dude, most are pretty much the same, just little minor differences like the weight, height, and palm rest area, so don’t insult me with “oh you’re playing on a different stick so you’re just not used to it” dude ive maybe gotten used to a brand new stick in the past within couple hours, its not rocket science…its like driving my friends car, i can get used to it real quickly, nothing new.