Issue with LT and RT buttons on my BlazBlue 360 TE stick


#1

The LT and RT buttons on my BlazBlue 360 TE stick randomly die on me. And when I unplug and plug it back in I works again temporarily. Help gaiz? ;_;


#2

http://shoryuken.com/forum/index.php?threads/149353/
http://shoryuken.com/forum/index.php?posts/6311183/


#3

Have you opened it and confirmed that all of the wires are secure? Check the quick disconnects of the wire and where it’s soldered onto the PCB.


#4

Please try the instructions in JDM’s second link first. They’re easier to do, and I’m always looking for other folks to test it out.
(Does this mean the TE-S based sticks have this problem too? Hmm.)


#5

I’m assuming there isn’t anything more noob friendly for the fix?

Yes, everything’s secure.


#6

More n00b friendly that this?

Umm, no. There’s not. The first link is n00b scary, absolutely, but the second one? It’s all bolts and two wires. As soon as I get confirmation from another about it working, I’ll get some photos up to help do it, but it shouldn’t be scary at all.


#7

I’m sorry if this make me sound like a complete idiot, but what’s a gauge?


#8

For what it’s worth Toodles, last year I connected the USB shield to the bottom plate of my Round 2 TE (and disconnected it from the power ground). I only rarely had problems with the triggers before that, but haven’t had any since. I figured it was inconclusive though since I did it towards the end of static season.
(I didn’t ground the top panel but since I replaced the top screws with plastic there’s no exposed metal there either. If I replace the bottom panel with plexi I suppose I could probably get rid of my static problems all together.)


#9

So I think I get the idea from that link you sent me Toodles. But I’m lost on the last paragraph about the rows of QDs are only 2 rows of QDs unless you’re referring to columns.

Here’s where I got lost:


#10


| | | | | | | | | |
| | | | | | | | | |
  [   ]     [   ]


That’s the distrobution board. Each | is a spot where a QD plugs into. Each [ ] is a ribbon connector.



* | | | | | | | | |
| | | | | | | | | |
  [   ]     [   ]


The spot * is where you want to shove the wires in with the QD.


#11

I am doing something wrong. My stick stopped working unless I remove them.

Edit:I lied. I disconnected something. Hope this works.