Issue with USB 3.0, TE-Fightsticks/HORI Fighting Edge (both xbox 360) and Win7 64-Bit


#1

Hey Guys,

i recently bought myself a new Notebook. I was very excited about that because i also want to play my fighting games on it.
After yesterdays evening 5-hour-search and no solution for this problem, i wanted to ask you guys, if someone could help me because i
guess im might be not the only one having such problems.

Everytime i plug-in one of these Sticks named above, my device manager recognizes them properly (with name) but it cant find any sort of driver and install it.
Also the microsoft driver doesn’t work.

So does anyone have a solution for this? because i cant help myself anymore.

thanks in advance
Mic


#2

Is your sticks for PS3 or Xbox 360?


#3

They’re all for Xbox 360.


#4

Try to install the 360 driver manually, go to http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows download and install and you should good to go.

I have the same problem when I have to format my gaming pc and this was the only solution I found… and still working like a charm!


#5

Yeah i also read this, but the problem is:
There is only the .exe file.
Where can i get a simple driver file (dunno what it is? .dll, or .ini or smth like that) which i can pick for the manual installation because i cant pick .exe for a manual driver installation.


#6

Wait, what OS are you using?


#7

It’s a Windows 7 Professional 64-Bit Version.


#8

Its Win7 64-Bit version… and I’ve just downloaded that exe file from the link I leave and that’s all you need.

Just run it and you’re set!


#9

okay
ONCE more, i deinstall the driver now, because i already downloaded from the page you posted.
and then we will see


#10

and it still does not work dude…
the xbox controller is no problem, its recognized and installed automatically.
but when i plug in the fighting edge or the TE stick IT DOES NOT WORK. windows is searching for drivers and it cant find any and cant install the stick.
but its recognized in the device manager…

…shit pisses me of… srsly
sorry :frowning:


#11

I JUST HAVE FOUND THE SOLUTION!

-made a bios update
-went to bios
-switched the USB 3.0 Function to “disable”
-went into windows
-plugged the sticks in
-went to the device manager, and installed driver manually (but automated websearch)

now they are working well!

:smiley:

thx to you anyway <3


#12

So, the whole problem was the USB 3.0… oh well…


#13

I have had this problem with my USB 3.0 slots too. I haven’t tried disabling USB 3.0 functionality, but plugging in sticks via a USB 2.0 hub works for me.


#14

So you were plugging the stick into a USB 3.0 port?