Issues with a modded SE


#1

In july I decided to mod my SE stick for the 360 and today the x button is unresponsive. To get it to activate i have to push the button with considerable force so would the issue be with the wiring and quick disconnect or is the button itself broken


#2

Best way to check is to open the stick, disconnect and reconnect. If it is still not working then disconnect and replace it with the “Y” button. If the “Y” button (that is now substituting for your “X” button) isn’t working either, then you have ruled out the button as the problem.


#3

could be the button.
Did you open the button at all to see if it touches the switch on it?


#4

I think it’s easier to check the button by hooking a different pair of quick disconnects to it, and checking if the problem persists.


#5

Most definitely the switch in the button. There are no reason to believe there is a connection issue if more force will make it work better.

To confirm, simply open the case and try examines the switch manually. If you short the connection with something conductive, does the key press get registered in the game reliably? if it does, then it is clearly the switch in the button. If not, then something else deeper is the problem.

What Yon and Rufus suggested will work just as well. Switch to a different button, or use a different quick connect. Whatever. The point here is to isolates the problem and confirm that the PCB is not the issue.


#6

solved the issue turns out the quick disconnect was not properly attached to the button


#7

lol but good to you bifbo now get on the playing field