Issues with padhacked buttons


#1

I am currently making my own custom arcade stick using an xbox 360 wireless controller.

I have the majority of the wires already soldered to the pad and have been testing the connections with SF4. The buttons seem to work fine in all the menu’s, but once I get in-game the A and B buttons cease to work. I have tried switching to another controller and the other wireless controller seems to work fine. Anyone have any idea what my issue could be?

Thanks in advance.


#2

Give us a pic


#3

and some pictures of both the triggers


#4

so the A and B works in menu but stops working IN GAME?
i can’t quite understand it. we will need to see a pic maybe your controller isnt a common ground


#5

This.

I ran into a similar problem when I soldered my wireless pad. Turns out the triggers weren’t set to the neutral position (I still had them in) so the game thought it was being constantly held down. It worked after I unbinded the trigger buttons.


#6

Sorry, I can’t seem to find my camera at the moment to take a picture, but I think you might be right about the trigger. If the left trigger was stuck “on” then that means that 3 kicks would be held down and the other kick buttons would not work in-game.

I hadn’t thought about that as i only removed the plastic casing from the triggers and left the small black box that it was connected to. I read in another thread that you need to install 10k ohm resistors for the triggers to properly reset, so I will try that and see how things work out.

Thanks for the input guys, it is greatly appreciated.

I’ll post some pics of my setup when it’s all done :slight_smile: