JLF died


#1

So i got a JLF w/ mounting plate from AKi… (nothing against you guys)
so it was brand new about 2-3 weeks ago.

Swaped out the madcats, very simple process, im no newb with electronics.

today the UP position stopped working??

i tried unplugging the USB and trying again, restarting the 360, open the stick, check for physical damage, check microswitches for shorts or any burning or anything.
Checked the wiring harness…

EVERYTHING else works, left, right, down, buttons, start/select, turbo, etc.

any ideas???

what can i do? wait another month to buy another stick? get a microswitch? bahhh im pretty pissed off with this whole project…Sanwa is supposed to be top notch right?

and no more SE or TE for Canada for quite some time, due to that fiasco in china with the plants or whatever…


#2

you have a multimeter?

If you do check the resistance on the up microswitch.

could be grime or dirt in between the contacts open up the jlf take out the pcb , open the microswitch and clean it off.


#3

Who said it was the stick? The fault could be in the PCB or in the wiring somewhere.

If you still have the original stick, plug it in and see if Up works.


#4

The PCB of the JLF may have worn down somehow, does your up switch still make a clicking sound? if so and the old stick works with Up, then your PCB is fucked. It’s really easy to remedy if you have a souldering gun by just soldering a wire directly to a switch. I have a few joysticks that I did that to just because I didn’t have a quick connect handy at the time of an install


#5

I had the same problem with one of my jlfs…
swapped out the microswitch board and it was fine…

no idea what was wrong with it… :3


#6

happened to me last week, except with the down direction on my jlf. i just opened up all the microswitches and cleaned them out. everything works fine again, i guess there was a lot of dirt/dust that got built up? not sure, but it works now.


#7

If its the PCB, maybe you could solder a wire directly to the up microswitch and bypass the PCB for that direction.


#8

sounds excellent, you guys are awesome.

All i can say is it still clicks, im going to dive in right now. Will post the results.

Im hoping its just dirty…i smoke and drink in my place so its highly probable its grime or dust.


#9

chances are it is or maybe the switch broke but that’s pretty uncommon, I doubt it’s the madcats pcb something serious would have had to happen to cause a short.

You definitely need a multimeter to be sure of anything though.