JLF Input Problems


#1

Hey guys, I’m hoping you can offer some advice for a problem I’ve been wracking my brain over.

So I have a Panzer Fightstick Widebody Case, with a JLF-TP-8YT in it. Whenever I try and do a fireball motion from the 2p side, I don’t get the diagonal motion. I just get a clean, down and left input. I also noticed that sometimes when I try to jump forward from the 2p side, I’ll just get a neutral jump instead. At first I thought it may be the microswitches, but I tried 3 different microswitches and I experienced the same problem.

I then tried switching the square gates out, after a friend told me that they can get worn and eventually make it harder for the actuator to activate the switches. I don’t know if this is true, but I tried it anyways… but still had the same problem. I had a Kowal Actuator on it, and I switched it out for the stock JLF actuator. Though I didn’t really think this would fix the problem, I was getting really frustrated.

After that, I took a look at the Shaft Cover and Dust Washer I had on the stick. I decided to take them off and lo and behold, the fireball inputs felt normal again. However, I still don’t know what the deal is and how the shaft cover and dust washer affect the stick.

Can someone shed some light on this issue, or maybe I’m just going crazy? If I move the stick around with both these items on, it doesn’t look like it’s touching the sides or anything to keep the switches from activating. I really don’t know what the problem is…I’d really like to be able to keep the Cover and Washer since it fits the color scheme of the stick.

Any insight guys? I have no clue why this is happening. Any help would be greatly appreciated.


#2

the shaft cover and dust washer shouldn’t be messing with inputs at all, Anyway, it sounds to me like the TP-MA assembly might need to be switched out on your JLF. I had something similar to me happen at a Texas Bar Fights tournament (one of the last at the Franchise out in Plano) and I had to borrow sticks for my matches.


#3

Was the shaft cover seated correctly inside the inner dust washer (assuming you have both dust washers on, of course)? If it’s not popped into place, you will get extra tension on the spring, which may have been throwing you off- should have felt a lot different though.

If you’ve been soldering new microswitches into the assembly, it’s possible that the first was worn, then the next two weren’t centered correctly. Removing the shaft cover would have no effect in this case.


#4

To clear things up, I was switching out the TP-MA assembly like Mike suggested.

But the thing is, the stick is practically brand new. I changed the actuator, but I just changed it back to the stock part last night. Also, I removed the second dust washer (the one that sits under the shaft, since I had a Link Shaft in it for a bit.

As of right now, it’s completely stock aside from the missing dust washer.


#5

just a note just because a part is brand new does not mean that it cannot be defective especially with cheap mass-produced electronics


#6

I’m at a loss, given that you’re saying removing the dust washer and shaft cover fixed it. What pcb are you using?


#7

Man… I feel the same way. I have no clue what the deal is.

I’m using a PS360+. I’ll try out some other JLFs when I get home tonight, and report back.


#8

So I took the stick out of the case and disassembled it. I noticed that the small metal washer that sits above the microswitch assembly was sitting backwards. It looks like one side of it is completely flat, and the other is rounded just a bit. It was sitting with the rounded side face down, and when I would move the stick, it would pop out of the groove it’s supposed to sit in, and eventually push itself up against the PCB for the microswitch assembly. I must have put it back the wrong way at some point.

BUT… even after putting the washer back the way it’s supposed to sit, I was still experiencing the same problem. The washer would sit perfectly in place when I’d move the stick around, but inputs were still wonky.

I took a REALLY close look at the stick and moved it around slowly so I could see if there was anything else interfering with the actuator and switches. After a bit I noticed it -

My JLF shaft is bent.

It’s a VERY slight bend, but it’s just enough for switches to be barely out of reach for the actuator. So I threw my Link shaft back into it, and it works like a charm now. Ugh. FINALLY.

Thanks for the input guys, I appreciate the help! Special thanks to @sethian0 who got me to sit down and take a real close look at my “brand new” JLF. I’m so relieved my stick is working properly now!


#9

NP BRO!!! welcome to the club! glad you got it working! we’re all a team here!


#10

Glad to hear you figured it out, that was a weird one.