Joystick Button Registering 2 Buttons each Press


#1

Hey everyone,

I am having some serious issues with my XB360 Rd.1 TE stick. I bought this stick already dual modded for XB360 and PS3 (there is a IMP, and a Chluthu(sp?) boards soddered to the original XB360 boards ). Worked perfectly fine for about 2/3weeks, then the below happened.

Now my issue is that when I press X or Y (light/medium punch mapped buttons) both X, and Y register. I have done what seems like days of sitting in practice mode with inputs turned on, trying to disconnect one button, and pressing, disconnecting the other, pressing, etc. etc.

What I have discovered is when just the medium punch is connect I get just a medium punch. when just the light punch is connected, still get a medium punch. When both are connected, get light+medium for either button pressed.

Not sure what the heck is going on here at all, and would love any advice that anyone can provide. If you need any more info, please post I will do my best to answer your inquiry.


#2

It sounds like there’s an electrical connection between the ‘hot’ sides of the buttons. Probably a wiring issue.


#3

This sounds like your signal wires may be crossed some where. Where did you disconnect the buttons from? Also, a few pictures of the wiring may help. Where are the wires connected to the Cthulhu board soldered or connected to at? It sounds like some play may have jiggled your two signal wires to connect to each other, and it sounds like it may be a short circuit near the actual wire of the pushbutton. But I don’t know how it is wired, and that’s why a few pictures would be very helpful.


#4

thanks! I will get pictures taken tonight, and also attempt to test the “hot” side of the connections. I will post results along with the pictures.


#5

I can’t tell about a specific PCB you have, but I have had the same problem with some Logitech’s. I had to shorten a wires because they were too long. Maybe that is the problem with your stick.


#6

Hey folks on behalf of CSquared I uploaded a few photos of his stick. Any advice you can give will be very much obliged. Totally bizarre can’t seem to find out what’s wrong.

TE Arcade Stick - a set on Flickr Link to the set via Flickr.


#7

Thanks, those were some really quality pics. I see where the short circuit probably is. See this picture: I | Flickr - Photo Sharing! ? See how some of the wires are a bit exposed? I think two of them may be touching, which is causing your problem. I would make sure that you bend the wires a bit so they are farther away from each other so they don’t actually touch, than apply some electrical tape after it all tests and checks out to make sure that everything is okay.

Also, +1 for Neo Geo corresponding buttons. :tup:


#8

Thanks Nerrage, I will try what you suggested tonight after work. And post the results tomorrow (only have interenet at work at the moment). Your help has been really appreciated!


#9

Looks like Nerrage was pretty spot on.

After “cleaning” up the loose wires in the area Nerrage suggested, it went back to normal for a bit. then started again. So using the clever art of deduction, I figured if one end of the wire was exposed the maybe the other end was as well.

Sure enough it was, on underneath the normal XB360 circuit board where the wires are soldered in. This will (of course!) require some re-soldering to properly correct. Yeah Weekend of soldering, and no fighting games. I need to be either more gentle on my stick, or get better at soldering. NO.2!

Thanks again to all that assisted in my bizarre week of stupid stick malfunctions.
MooCHO APPRECiATO!


#10

Ah, didn’t see the soldering on the 360 PCB. But if that didn’t work, that would have been my second suggestion. It should be a simple fix. I would get just a little copper braided wire to suck up just a little of the excess.

Glad to have helped. :tup: