Joystick no inputs, trying to fix, any suggestions


#1

Anyone have any clue as to how this could have happened or what might have gone wrong?

I was playing yesterday (Modded WWE Brawlstick) everything was fine.
I went to the bathroom and when I came back my buttons worked but the joystick was not recognizing any directions
I figured the Sanwa harness might have come loose, I checked it and nothing was out of place, unplugged and re-plugged it but still nothing.
I quickly turned it over and checked that the LsDpRs wasn’t the problem, was on the Dp, moved it around and checked, still nothing.
I didn’t know what to think, but I had another Sanwa pcb so I got it and plugged it in, still nothing
I didn’t have another Harness with both ends but I did have one with only the side that plugs into the sanwa pcb and loose wires on the other end.
I started checking online but couldn’t find one with both sides.
so I figured I had to de-solder the female end that’s in the main pcb & hook the harness loose side straight to it.
I busted out the soldering iron and de-soldered that part, I placed the harness wires into the holes to try and see if I could get any inputs out of it before soldering it up and nothing.

I don’t know if just placing the wires in the holes would be enough to get an input to come out, but with most electronics I’ve messed with it should be enough to at least get a sign that what your about to do will work, I decided to come and post this to make sure what I am doing is right before I go ahead and solder it up just to see if it works. I haven’t gone ahead and done it just because it’s not showing any sign of hope that it will work.


#2

Did you check the USB cable for continuity with a Multimeter?


#3

Don’t have a multimeter handy, would the stick be turning on, because unplug, replug working fine. What should I be doing with a multi to test? and what am I checking/looking for exactly?


#4

also just realized and I forget to mention that the stick has a Neutrik Jack installed


#5

Nothing to do with it really. It is highly unlikely its the cause unless you got a older Neutrik that old and worn out.
You can bypass it and make a quick test to make sure.

Got some batteries, some spare wires, and a LED? build a quick and dirty Continuity tester and test out each wire in your USB cable, on both sides of your Neutrik.

Protip: for future modding and repairs a Multi Meter is a good investment
here is a reasonably priced multimeter that works pretty well.
https://www.adafruit.com/products/71


#6

I don’t really understand too much of what your saying I should do.
How do I do the test on the multimeter?
as in what am I supposed to be touching with it?
not really understand what you mean about each wire in the usb cable?
In my head it sounds like cutting the cable and testing the insides but I’m guessing that’s not what you mean.


#7

Do you know how the stick is supposed to work - electronically?


#8

not exactly, I’ve only messed with buttons and sticks for the most part, I did splice the original usb to Ethernet (or whatever) for the neutrik jack, that was done over a year ago, been playing on it without problems since then.


#9

Here is the construction of a USB cable

As you see there 4 main wires in a USB cable, Red, White, Green and Black. Ignore the “drain” wire as you not be using it.

Here is the Pinout of a USB cable

http://image.pinout.net/pinout_USB_files/usb-pinout-diagram.gif

-source http://pinouts.ru/Slots/USB_pinout.shtml

The VCC provides power, and ground is for retun voltage.
Or you can think of it as the same terms as a battery.
A battery has Plus (+) and Minus (-) sides.
So to does Direct Current (DC) electrical wiring.
VCC is + and Ground is -

Data + and Data - are for communication between your controller and game system or PC.
Think of it as the 2 lanes of a road, one with info going to the stick and one with info going to the console.

If any of these wires are cut or broken inside your USB cable your stick will stop working.
A cut in the red or black wires and your stick gets no power.
A cut in the white or green wires and your stick can’t talk to your game system.

A Multimeter is several electrical tools in one, it is a volt meter, amp meter, resistor test (test level of resistance) and a Diode tester all in one.
Putting a Multimeter on resistor test or diode test can be used to check continuity. Continuity is simply can electricity follow in a conductor (wire) or not.
I like using Diode test as the multimeter will beep.

You use the two probes of the multimeter to probe both sides of the USB cable, using the pinout above for each position.
Check to see if pin 1 on one end of your USB cable works with Pin 1 on the other end, repeat this for pins 2, 3 and 4.

Check You Tube on video guides on how to use a multimeter.

If for some reason you pins test continuity on the wrong opposite side pin, for example pin 1 on the device side and pin 4 on the cable end then you have whats called a cross or a cross circuit
where two (or more) wires are broken and the metal from the wires are touching.


#10

If the buttons work, the USB cable is probably OK.

Ok, there are typically five lines - one common, and four signal lines. When you push the stick in a direction, it shold close the circuit between the common and one of the signal lines.

If you have a meter, you can check the resistance between two of the wires and move the stick around (this may require four hands) and see if its working electronically.

It may be helpful if you post pics of the wiring in your stick.


#11

Thanks for the help in trying to solve this, I’m with Rufus on the idea that the usb is working, I don’t really feel like cutting the thing up unless I have to at some point.
Rufus I’m kind of a dope when it comes do the meter and reading it, what do I need to do exactly? as dumbed down so a moron like me might understand.

also just so you know as it is right now the main pcb has holes for the ground and directions and I have a Sanwa harness attached at the stick with the other side 5 loose wires, so from there how would I go about testing


#12

Before you start tearing apart your stick, is your buttons working, is your stick getting power?

Its easier to fix/replace a USB cable that it is to unsolder and solder a joystick harness.


#13

Stick is getting power, home buttons turbo etc work, the buttons work…just the joystick isn’t

also read your post from above really helpful, I get what you were trying to get me to test and why. I’m guessing its not my problem like Rufus mentioned since the buttons are working.


#14

Idea with trouble shooting is you start with the easiest most simple cause/problem and you work your way up to the harder and more complex issues.

Now we determine the rest of your stick works. Did you resolder the joystick wire harness in the right order?
Often with Mad Catz sticks, a common issue/mistake is putting the wire harness onto the connector on the joystick upside down, and the wires do not connect to the right pins.


#15

I tried the original harness both ways and no dice

I haven’t soldered the new harness in it yet I was about to and then decided to make this thread,

reason being that I placed the harness wires into the holes to try and see if I could get any inputs to come out of it before soldering it up, but didn’t get anything

I did notice that on this wiring harness from focusattack the red is ground, tried putting them in the holes with that in mind but not an input. usually with some stuff you don’t need to solder to get a sign that it would work and since I didn’t get an input I decided to hold off on soldering and make the thread.


#16

wire colors are arbitrary, they are just for identification. Technically if I made a harness I can choose any wire color I want for each direction and ground.
Its where the wires go on both ends that really matters.

So does the WHOLE joystick does not work or only certain directions?


#17

whole thing wasn’t working
1st thought the harness slipped
2nd thought I might have moved off of dp setting
3rd switched plugged in a brand new sanwa pcb and didn’t get any directions
so I came to the conclusion that it was the harness but the only other harness I had only has the one with one end so that’s why I desoldered the female part on the main pcb, and like I said I just tried sticking the bare wires in the right spots without soldering first just to see if I could get a connection just enough to make all four inputs come out as an indicator to go ahead and solder.


#18

I agree with @Darksakul that color is arbitrary but the order is important here. What is the order of the wires at the plug end?

One very simple thing to do is plug the stick in and try using another wire or paper clip to simulate the switches closing. Let me know the order of the wires and I can make a quick video showing you how to do this.

Also, if you can take a picture of what your set up looks like, close up on the joystick and harness with the control board. Pictures can be worth a 1000 words.


#19

what do you mean by order of wires? the colors on the harness?

They go: black green yellow orange red

but Ill try an take a pic


#20

some pics:

This one is how it should be: http://imgur.com/xGGC4j8,ZMRULh5#1

I think this way with the sanwa harness from above is better so the harness isn’t mushed up into the side of the case:
http://imgur.com/xGGC4j8,ZMRULh5#0