Joystick not working on PC AE


#1

I have AE on steam, and a mayflash stick. The buttons can be set, but not the directions. This stick works on PS2 and PS3 so it’s not broken. Advice?


#2

If it’s a playstation stick, then that’s the problem right there. I never tried it, but what I’ve been hearing is that xbox sticks are more desirable over PS3 ones due to recognition issues on PC.


#3

This stick worked for vanilla and GGPO.


#4

Haha I didn’t know that… actually I don’t really know anything at all, my reply was just a bump for your sake and others who might be getting a stick for this soon. But anyway, if you scroll down the forum a bit, there’s a thread about compatibility issues with PS3 sticks. Says something about buying a new USB card or something. Here’s a link to save you the trouble:


or


#5

Unfortunately it seems there are no fixes. Input delays with xpadder makes it unusable, I’m told


#6

I use a PS3 TE, and had a similar problem; Turns out setting the directions only works when the selector switch is on one of the Stick positions, not “DP”, so I have to have it set to “LS”.


#7

change to LS instead of DP


#8

It’s a Mayflash stick, which should work on any PC.

I suggest that you go into game controller settings in the control panel, then try your joystick with the settings on analog and then on hat switch to find out if any or neither of those settings work in AE.


#9

I am having the same problem. I had a HRAP3 SA and I can set the buttons but not the directional to the joystick.

Edit* I got it to work.


#10

Mayflashe sticks are mapped to the analog instead of the D-pad AFAIK. I don’t have AE on PC yet, but some games that I use my modded mayflash with required me to switch the analog option on, so check and see if AE on PC has that option or to use the LS like others have been saying.


#11

Do you have nvidia parts? I heard there is still compatibility issues with nvidia and certain arcade sticks. This may be fixed now, but a couple months ago i couldnt get my 360 mad catz TE to work on my asus g53. Even with the drivers.


#12

Hmm, seems my TE has run into some problems as well. It worked fine on my old Asus socket 775 motherboard and ATI/AMD gfx card. But now with Asus 1155 and Nvidia card it shows up in hardware as usual, but I can’t calibrate or get it to work with motionjoy and whatnot…

And yes, it is set to LS. Hoping some drivers can fix this, and that it isn’t the Nvidia card messing about. Motionjoy can’t find it/install drivers, but I remember having some joystick driver with a Z in the name, can’t remember what it was atm tho.


#13

I’ve heard that getting a new USB card solves compatibility issues, but how can i resolve this if i have a laptop? is it still possible to switch out the USB card? i dont think so but I want a solution to this issue.


#14

also has anyone tried a USB extension cable? would that be an easy fix to get around compatibility issues?


#15

When I test my Mayflash stick (which does not have LS-DP-RS switch) in the Windows 7 controller config thing, both the analog and POV hat moves. Is it possible to disable one?


#16

I have an nVidia motherboard. Does this thing have drivers I can update?


#17

I dont know if it does on ps3. For the 360 i had to go to the xbox site and download them… They still didn’t work.

I wish i could help you more but maybe lookin on madcatz site about ps3 combatibility. I know your stick is not a madcatz but i recall them saying something about ps3 compatibility.


#18

There are only compatibility issues with PS3 Mad Catz sticks with certain motherboard chipsets. Hori and Mayflash PS3 sticks can work on all PCs perfectly fine, and the Mad Catz PS3 Chun-Li TE-S has a revised PCB that works on all PCs.

Your Mayflash stick should have come with a CD-ROM with the joystick drivers on it, or you can get the drivers for your stick from the Mayflash website.


#19

thanks for clearing that up.


#20

This is the only thing I found on Madcatz site regarding ps3 stick > pc:

Q: My PS3 Arcade FightStick (TE and Standard) or PS3 FightPad is not working on my computer.
A: The PS3 SFIV TE/SE FightStick and FightPad does not officially support the PC, but should work with PCs that do not make use of a NVIDIA® chipset. If a workaround is discovered, we will post more information for you here.

I recently bought a new computer with:
ASUS P8P67 DELUXE B3 P67 S-1155 ATX
INTEL CORE I7 2600K 3.40GHZ 8MB S-1155
ASUS GEFORCE GTX 560 TI DCII TOP 1GB PCI-E DVI/HDMI

Old pc was:
Asus P5B
Intel Q9400
ATI HD4870
and the stick worked fine on that pc, just Plug and Play, no extra drivers needed.

So the only Nvidia product I have is my graphics card, which I doubt(?) could have anything to do with the stick not working. The stick shows up the same as it did on the old pc, both in device manager and in AE. It just doesn’t register inputs in AE, motionjoy, xpadder and hardware settings/calibration (tried LS/DP/RS but always had it on LS on ps3/old pc). Searched around a lot yesterday for a fix, but I only found drivers for xbox and hori controllers. I really hope there is something that I’ve missed that can get the stick working again. Anyone else with a similar pc/similar problem that got it to work?

I don’t really feel like going back to ps3 after spending money on the pc version + using good pc, but I guess that is better than importing a new chun-li stick, if they are working with every pc as was said above. And I do need to import, since no online reseller got the sticks (found one with the original sf4 TE) and the previous reseller I bought from, who at least had the ssf4 stick, no longer got any left. Curse you Sweden!

Meh…