Just made myself a stick with the cthulhu, but it has weird problems!


#1

Hey guys, I just finished making a prototype hitbox for myself using seimitsu buttons, and some hori buttons (for start, select and home), and with the Cthulhu Multi-Console PCB. But after setting it up and plugging it on the computer, all of the buttons don’t work except for the start button. I figured I didn’t ground it properly so i used the start button’s ground wire on some of the other buttons and it still doesn’t work.

It says the driver’s been installed fine and the computer can identify it, even on SF4 (says cthulhu multi-console edition). The only ones I haven’t setup on the cthulhu are the L1 and L2 buttons.

Nothing happens when I press down left right lp mp hp mk hk select

the start button works fine when pressed, and while holding it the select button can work too

This is what happens when I press the light kick or the up buton, and it always gives that windows sound that there’s a device that’s been connected/disconnected.

Here’s how my prototype looks like

Please help I don’t know what to do, i’ve tried plugging directly from the cthulhu to the pc without going through the switchable plug (located on the outside of the box). Also tried combination of buttons while holding select or start to see if any worked, but none. Would updating the firmware help?


#2

Also, the wires were bought with the buttons too, so they’re really long. The only thing is I didn’t cut them, so I just wrap them up around there. Would that be a factor to this problem?


#3

The black GND wire connecting the majority of your buttons together - which screw terminal is it connected to? It looks like it is going to the VCC terminal… if so then that would be a critical error.


#4

I can see what you’ve done, you’ve got the ground wire for start/home plugged into the live terminal for start, I’ve no idea what you’ve done with the rest but that’s why your start button works and nothing else.

Swap the grey and black wires marked and you might find you have more luck, also check, check and double check all of your connections… If you’re having trouble disconnect everything, connect the grounds and try connecting one cable at a time, testing as you go to make sure everything is correct.

http://badhorse.izit.org/Image002.jpeg


#5

It seriously looks like you’ve wired it up ‘upside down’. You’ve got all of the buttons going to the stick area, and visa versa, like the Cthulhu was upside down from the labelled image in the welcome sheet. Take another peek at the labelled image in the welcome sheet that came with the board, and I’ll bet it’ll you’ll see the difference. The image in the welcome sheet with the labelled screw terminals is as if you’re looking down on the board, with the chip,jack, and screw terminals all facing you.


#6

Ill go check again while doing the opposite, i followed this diagram thinking it’s the same thing as the one in the manual. Is it possible I could’ve broken it? Is it because of that 5V slot? =(


#7

The diagram you posted is correct, but it seems you were looking at your own Cthulhu upside down:
The diagram has the USB jack pointed to the bottom of the screen; it looks like you wired it up as-is with the USB jack pointed upwards…


#8

Use this diagram instead, it is clearer:

http://www.godlikecontrols.com/download/PS3CthulhuWelcome.pdf


#9

The pic you posted is correct bit like everyone else has said you’ve got it upside down. The image you linked is taken from the top of the board but because no electronics are currently soldered to the example board it looks upside down.

Your mc Cthulhu is unlikely, to be broken. Just rewire it, and I’m sure you’ll have it working first time.


#10

The easiest thing to do would be to remove all of the wires from the screw terminals for now, and focus just on getting the joystick going first, then adding the buttons testing as you go.
Remove everything from the screw terminals, then take the four wires from the directions and screw them down in the Up/Down/Left/Right screw terminals according to the pictures. Take the end of the black wire daisy chain for the directions and play buttons, and screw it down in the GND screw terminals next to the directions. Plug it into the PC and test the stick to make sure the directions are working. Then add the start, select, and home buttons and the ground wire for them into the matching screw terminals; you can use any of the GND screw terminals for ground, even doubling up with the one you used for the stick if you want. Test it out so the buttons light up on the PC. Then add a few button signals at a time, test, then add more.

But nothing you have should go to the VCC/+5v screw terminal. Leave it empty and you wont see that disconnect message.


#11

THANKS ALOT GUYS! It’s working perfect now! I thought the diagram I was looking at was upside down but it was basically on top! I know I messed around with the +5V terminal for sure now, but I’m glad that didn’t ruin anything on my PC or PS3 =/. Thanks again =D!