Kaimana RGB LED Board thread, RGB animations and more! SRK Tech Talk 2013 Product of the Year!


#1181

Guys this is my first time setting up my kaimana mini and i’m having issues uploading the example sketch to my board. Every time i try to upload i get this error. I’m on windows 10 and i have also tried this on windows 7. Also i tried different com ports and i get the same error. My kaimana red led on the board comes on and the leds light up as well. Any help would be appreciated. Thanks!

Arduino: 1.6.1 (Windows 8.1), Board: “Arduino Leonardo”

Sketch uses 13,212 bytes (46%) of program storage space. Maximum is 28,672 bytes.

Global variables use 278 bytes (10%) of dynamic memory, leaving 2,282 bytes for local variables. Maximum is 2,560 bytes.

avrdude: ser_open(): can’t set com-state for “\.\COM3”

avrdude: ser_send(): write error: sorry no info avail

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.


#1182

I think i got it working now. It seems as soon as i plug in my USB hitting upload worked. Not sure what was stopping this before, but i works now.


#1183

Dude! So excited you got it to work!

One last question, after that can you reupload code without doing the special process? This might be a workaround for some other users that are experiencing the same issue!


#1184

Yes sir! I tested it to make sure i didn’t have to do that special process every time.


#1185

If you get the latest code version you should be able to just change the brightness value in the settings.h file.

https://minhaskamal.github.io/DownGit/#/home?url=https://github.com/javierorosario/kaimana/tree/master/KaimanaJ2s/8btnFull

Excellent thanks for the info!


#1186

Update:

I got the board to finally upload a Sketch of @JRDIBBS thanks to some help from @Vicko giving me some help. only have one issue now, the buttons are all set to the right lights in this order Kaimana > P1>P2>P3>P4>K4>K3>K2>K1. The Buttons and the Screen Saver mode work no problem.
However the issue is, as soon as I engage any switch on the Joystick, The Lights freeze. If I have nothing pressed, the lights will stay totally off, If I’m holding 3 lights when i press the joystick, they will stay on. the Screensaver stays off as well. It’s basically stuck like that until i Disconnect the Panzer from the power. I’ve Checked all the wiring, and everything else I can think of. Vicko had to get running, so I figured maybe JRDIBBS might have seen this before? all the coding seems to upload no issues at all. so I don’t know if there’s possibly something in the code. its your J2s.ino file I\m using!

Anyone else possibly ran into this??


#1187

Hello!

I haven’t seen something like this before. Can you send me the URL of where you downloaded from? I can help you out a lot more from there :slight_smile:


#1188

I sent it to him directly, from where you linked me to. I just changed the button order.


#1189

I believe it’s just your J2S file with the button order changed. Vicko emailed it to me to try, if you like i can send you the files i got. Just message me your email @JRDIBBS if you’d like it that way :slight_smile:
Thanks man…


#1190

So now arduino is stuck at uploading. I uninstalled the drivers and re-installed no luck. Completely installed 1.6.5 was on 1.6.1 and no luck, still stuck on uploading. Any help would be appreciated, thanks!


#1191

Never mind seem to be some kind of weirdness with the port. Had to change my com port #.


#1192

I’ve been lurking and trying to dig through this thread for the last week or so trying to figure out how to code for this or trying to find a basic code of just button press activates an LED, it’s been years but I used to code in visual basic and visual c++ in high school and was hoping to find a basic animation free sketch to experiment with and learn on.
I downloaded the files from the link jrdibbs had posted and ran into trouble.
I have a hitbox with a kaimana mini using j2 LEDs and I believe I understand how to renumber my LEDs for order and to make each direction it’s own LED (and how to rewrite the part of the sketch that handles directional inputs) but every time I try to compile I get “expected declaration before” errors on brackets on code sections I haven’t touched yet or have commented out and if I go so far as to just have direction code in there to test if I’ve done that right like i am right now then arduino sits compiling with the bar part way through and does nothing. initially i tried arduino 1.6.11 but now I have 1.6.4 which i think I’ve seen on this thread as the preferred version.
If anyone has just a basic code of lights activating to button presses I can probably do the rest and I’d appreciate it.


#1193

There’s no such thing as a codebase without animations. The closest is the original code and that still has the default idle animation. See below:


#1194

Thank you for the heads up and the link to more code to look at, being able to compare more code has helped me get a better grasp on this, I was able to get something going in a round about way for now that I can tinker with in my spare time to get more efficient and maybe more complex.


#1195

is there any kind of updated guide on how to program the kaimini? i have spent a couple hours browsing 4 or 5 years of old posts and I am completely lost on how to upload code to the kaimini. when i use the arduino software, it wants to go to a arduino board and I have no idea how it is supposed to find the kaimini. I have tried using molecule and have had problems with that as well, but that really isnt for this thread.


#1196

Did some digging through the code, got it to work now, no problems, it’s pretty much the stock code and colors. Thanks a bunch for the assistance @JRDIBBS you have been beyond helpful. I can’t wait to try setting it up in my next Panzer hitbox as well !


#1197

I am working on updating the guide but in the meanwhile you might want to review some tutorials that deal with the Arduino Leonardo to get the bare bones on how to work with the platform. I really enjoyed this one.

Hi again! Glad to know you got it working, I’ve been mad busy this week covering at work. Let me know if you need more info, this week i plan to spend some time refactoring code for the reasons below.

The latest news regarding the strange “Kaimana wont connect” issue, it seems it’s an issue with the code i built. Not the best of news but it’s good to be able to pinpoint the issue so we can fix.

Fixing it will involve tearing down the new codebase and rebuilding from the ground up with the known config. Hopefully this week I will get this done.

As always feel free to drop a comment here, PM me or open a ticket on the support site!


#1198

thanks for the info. The problem was that I was using the wrong version of arduino. You think everything would be backwards compatible. New problem though, when I tried to upload to the kaimana, i get an error telling me to reset the kaimana while it transfers. I tried changing the com port 4, and now im getting a com error. I tried changing back to com3 and it just hangs on uploading.

edit:

i plugged and unplugged several times and now it works.


#1199

Hey Guys!

So I just finished finished test building my new stick and everything installed without a hitch. I have installed the latest codebase for the kaimana mini and I have a couple questions about the animations.

  1. I am able to hold K1 down to put it into tournament mode, and t it works just fine. As soon I press K1 again though (not holding it down, just tapping it) ,it goes back to having the LEDs on. Is that normal?

  2. Are the animations supposed to work with all buttons? For example, I can start the fireball animation with P1 as well as P2, but when I try it with P3 or P4, I just get a regular button press. No animation. Is this normal?

Other than that, I’m hoping to add a Simon mode where you can play Simon with the buttons lol.
Looking at all the code documentation, the functions are pretty straightforward and turning lights on and off is simple enough. Hopefully I have enough memory left in the Kaimana to add this code and hopefully it all goes well.

Thank you all very much for these wonderful products and all the hard work you have put into all of this, as well as the forum. I read through the entire thing. Lots of good stuff lol. Keep it up guys!


#1200

Thanks for the kind words!

I thought I had solved the K1 issue, which folder did you download? I’m double checking my main branch to see if I actually committed it. After reviewing, the Fireball animations are only on P1 and P2, it shouldnt be too difficult to add P3 and P4 (though P4 would be Hyper/Ultra right?). I can add them if you are interested.

PD. I checked and the code at https://github.com/javierorosario/kaimana/tree/master/KaimanaJ2s/8btnFull is the one that has the fix, im in the middle of a gigantic rework so im trying to see about creating a single universal codebase.