Kitty TE > Sega Saturn - Lights but no control


#1

[EDIT]
Issue resolved. Traced back to a back Cat5 coupler. Geesh. The one thing I didn’t have at least two of to troubleshoot. :slight_smile:

Toggle below if you care to see my tale of woe.

Spoiler

Need the help of the elder gods here on SRK.

Wired up a 3rd party Saturn controller extender to Cat5. Followed the pinout guide, confirmed all connections. Fired up SF Alpha, and for the first part of the round, all controls worked fine. During the second round, all inputs on the joystick went dead. No lights on the guide or turbo panel. Unplugged, reconfirmed continuity, hooked back up to Saturn. Now, the turbo lights come on when I press a button, but no lights from joystick input. Worse yet, even though the Kitty is picking up inputs, they aren’t registering on the system.

At this point, I’ve tried it on two Saturns and a Dreamcast using an Innovation SS>DC adapter. Same thing (lights from the Kitty, no input on console).

I’ve confirmed that the ports on both systems are working with other controllers (and the SS>DC adapter as well).

Plugged it into my PC and it recognized as TE Kitty. Plugged it in with Turbo down and it recognized as a TE Stick. This was the only time this worked. I unplugged it, tried again with the PC, now it won’t recognize at all.

When I plug it into a PC, I get the exact same thing, along with a USB failure message. Same thing when holding down turbo to force the TE board. XBox 360 doesn’t work anymore, nor does PS3. Puts a damper on my weekend. :-/

[EDIT]

Took everything apart. Confirmed the TE board works on it’s own, as does the TE Kitty. Now I’m stumped.


#2

Ethernet cable


#3

Coupler, actually.