Know How: The Mad Catz Pro Cable


Would like make a post confirming that the pinout posted on the 1st page for the Panthera also indeed works for the Atrox.

On that note, does anyone who’s made custom cables for the Panthera using generic aviation connectors have any issues with how recessed the male connector is on the Panthera’s case? I tried it on my Atrox, but since the lug on the aviation connector isn’t as big as the one on the stock Atrox cable, I have a bit of a harder to screwing/unscrewing the thing. Wondering if the Panthera’s male connector is any more or less recessed than the Atrox.

Atrox with stock cable

Atrox with custom cable


I wish I can help you but my Atrox is an actual prototype I tested for Razer.


Xbox One TE2’s cable uses the same pinout as the PS4 version.


So to my understanding, any old usb cable would work here when creating a new pro cable? Just want to make sure before attempting this.



EDIT: Make sure it’s a charging and data sync cable instead of just a charging cable, of course.


I like using USB cables that are marketed for Printers and not Cell Phones.


Did you have to replace the factory male part with the aviation male connector in your Panthera /Atrox? how difficult was it to install the aviation male connector to Panthera /Atrox? Does it require a drilling or modification to the body of Panthera /Atrox?


Hi Guys,

First of all I’d like to thank the OP and all of you for the info I’ve found here - that was invaluable.

Second, let me ask if you have any ideas on why it could be not working - at least for me :))

I’ve found the comnector, I’ve soldered the cables firm, without any mess or interconnections, all acording to the pin out schematics above. The stick glows briefly, then PC informs about unrecognized device. Xbox does not inform about anything, just does not work. While using the second USB set of pins located on the stick interface board - everything works just perfect (on the PC and xbox as well)

I’m stuck. Is it possible I’ve mistaken ground and shield cables for example? Both are black…

Thanks in advance for any help!


Not really as the shield should be tied to ground anyways, mixing the two up isn’t an issue as their solder points on the PCB are directly connected to each other.
For Boards without a shield solder point/terminal, people will just combine those two wires together.

The thing that could hurt you is getting the Data + and Data - wires mixed up, and is a common mistake (even with us pros).
They are usually (but not always) the white and green wires in a USB cable


Thank you. Tested that - Changing white and green = same effect :frowning:

Prior to that, I was almost sure, that if black wires are shield / ground (doesn’t matter here, which is which - as you said) and the stick glows for a second, the red wire is in the correct place, and is truly a +5V. It would mean indeed that white and green are data and could be mixed up.

So i unsoldered the white one. The stick didnt glow and didn’t show up as unrecognized device in Windows. That didn’t yet mean anything, so I put it back where it should be (certainly one of the data pins in the aviation plug). Then I unsoldered the red one - the stick again didn’t blink or show up on a PC.

I think the red is the +5V and is placed where it should be, on the side of the USB plug (cannot disassemble it). Did anyone see the usb plug A to loose 5 wires cable, where one of the data wires was… black? If I’m gonna give it a try, would soldering ground to the data pins make any harm to the unit? I don’t think so, but asking just in case… :slight_smile:


PS Don’t have any multimeter, so cannot test it all at the moment.


You will need this for the USB pinout. Typically Black is ground, Red is power, White and Green are data. But not all cables follow those colors.

Don’t have a multimeter (which I recommend getting) Alternatively, if you got a LED light a battery and some wire, you can rig together a continuity tester


Well, I couldn’t sleep due to that, so I disassembled the USB A plug at the other end of the cable :smiley:

Guess what - all was correct there, white and green for data, red +5V, black ground… I had to rule out the broken cable, so I improvised a 5 pin plug which I connected with the spare USB pins in the interface board… And It worked - so the cable must have been ok since the beginning. “Aviation” plug is too simple in construction to be possibly the source of the problem. So there’s something wrong with the wiring between interface, and the male socket in the Atrox, no other way around.

I guess I’ll have to live with it. I’ll drill a hole in the Atrox’ case to mount the USB B socket and will keep using the other connector. It can’t be helped, methinks.

Thanks again for help!


Hi guys wonderful thread! I was building my custom pro cable and i wanted to ask a noob question about wiring. Where do i phisically connect the shield pin of the GX-12 aviation connector to the usb? Cause i’ve tried with everything connected but the shield and is still working fine. Do i really need the shield connected somewhere ? Thanks for any help :slight_smile:


Jesus, this is the kind of information that we can’t afford to lose!


Too true, especially since you can’t get anything from madcatz now. I was tempted to get a TE2+ a few days ago, and then I remembered that they folded so warranty support isn’t even a thing…


Go to print the page, but instead of sending it to a printer choose save as PDF.


Anyone see any problem with using 4 pin connectors vs 5. Shield shouldn’t really be needed.


Long as the shield tied to ground

Shield is there for Interference


No need; it just becomes a bit harder to unscrew because there’s less area on the female connector to grip

I never wired Shield to mine and I don’t have any issues. Might as well do it if you’re able though.