Levered sanwa microswitch question


#1

EDIT 1/28/12 post #8 details the revised problem as well as troubleshooting that I have tried

Recently, in the stick that I built, I noticed some problems with directional inputs. Specifically, down and any diagonals involving down were becoming difficult to pull off accurately and I would sometimes walk backwards when trying to crouch and block at the same time (very problematic!). I noted that the switch felt “weak” (for lack of a better word) in that location, so I decided to order a new set of four switches to replace the current four, partly because I felt the down was breaking, and partly just to tinker with my stick.

The switches that I ordered were one of the two options sold by lizardlick.com. I noticed that they had an extra bit of metal over the actuator. What I didn’t notice is the fact that they are designed to work with a jlw, not a jlf. I thought nothing of it–assuming that jlw and jlf were likely similar enough that such a thing wouldn’t make a notable difference–until they arrived today and won’t all fit beneath the stick’s gate at the same time due to the extra bit of metal crowding up the area. What I need to know is, can I safely remove that extra bit of metal? If so, is the best option to just rip it from the switch, or can I open the switch and lift it out more neatly? I suppose the option of just sending them back still exists, too, but I’ve been itching to replace these all week only to find that they aren’t quite what I needed.

Here are a couple of pictures demonstrating my problem:

This is them not fitting inside the jlf

and this is one of the new ones (with lever) side-by-side with an old one (no lever) for comparison


#2

I really hope someone will respond to this guys question because I’m having the same problems he does with down and up inputs.


#3

I’m assuming that there is a good reason you didnt just swap in a new TP-MA board instead?
Yes, you can remove the levers from the microswitch. You’ll see a seam around one side of the switch that can be removed exposing the insides of the microswitch. You should be able to remove the lever and put the side back on without damaging anything.


#4

Thanks for the info, Toodles! I’ll see about opening them up in a bit. As for the TP-MA board, I honestly have no idea what that is (and after a quick google search, I can see that may possibly (probably?) be causing problems as well). I decided to try a microswitch replacement due to the switch itself feeling like it had lost a good bit of the spring that it had about a year ago when I first started using this setup.

In the event that the switches don’t help anything, I’ll see about swapping in the TP-MA board.

Thanks again!


#5

Looking at your pictures, it seems that your current setup was connecting microswitches directly to wires(quick disconnects?). TP-MA is the JLF component that has the four microswitches sit on a PCB so they could be connected cleanly with a harness. It may be a little more expensive considering it’s a set of four microswitches, but it’s more convenient for most people. You could also buy the matching harness JLF-H. These are common setups on manufactured arcade sticks.

If you just want individual microswitches, you should have picked this:
http://www.lizardlick.com/Sanwa-MS-0-2P-Switch_p_308.html


#6

Yep, I’m doing the direct-to-microswitch soldering. This was the first stick that I ever put together (I’ve only done two so far, one for a friend was the other) and it certainly isn’t optimal. The harness setup that you speak of, the_third, is exactly what we did in my friend’s stick and it seems much cleaner. The next time I build one, I intend to use that style of jlf instead of the one that I am currently using for cleanliness and all that jazz.

I was actually able to successfully remove all of the levers, install the new switches and re-solder the whole project just now and everything is working fine! As for the awkward walking backwards while attempting to block low problem, it wasn’t all that common, but did happen occasionally, so I’ll have to play some matches to get a feel for whether or not that was remedied, which brings me to my question to Gyrcion:

When you experience characters moving the way that you described, does it occur after, for instance, tapping a directional input (specifically left or right) and then attempting to jump and jumping in that direction that was just tapped, even though you obviously jumped straight up? I ask this, because if you are using a madcatz fightpad pcb, those are built with a switch on the backside that swaps which analogue stick (or dpad) the dpad of the pcb corresponds to, and if what I just described is what you’re experiencing, perhaps re-adjusting that switch could correct the problem!

If that is not the problem (and even if it is!) perhaps a modding vet could offer better advice on how to fix what you’re experiencing, because i’m totally a newbie in this area.

Thanks again, guys!


#7

Also, just throwing this out there, you can order individual switches for the JLF TP-MA PCB, desolder the old one, solder on a fresh one. Though, that does require having a TP-MA in the first place.


#8

Instead of making a new thread, as my current issue is directly related to this thread, I decided to just dig this one back up. It’s going to be a really long post, I apologize in advance.

The symptoms:

  1. When holding the stick in the bottom right or bottom left corner positions (square gate), my character occasionally begins to walk backwards as opposed to blocking low.
  2. Sometimes, when holding down to perform a crouching attack, my character will not enter the crouch state and will perform a standing version of the attack instead. This is obviously easiest to notice at the start of the round when I can’t tell whether or not my character has actually entered a crouch state, but I have had it happen mid-match.
  3. Quarter circle inputs drop sometimes. When in training mode, this generally happens due to a lack of the needed diagonal input appearing between down and forward or back. SSF4 seems less prone to this problem (likely due to simple inputs?), but UMVC3 shows the missing diagonal often and the move does not get executed in this case.
  4. If I begin the backwards walk, a quick flick up to disengage the down microswitch’s actuator, then a quick flick back down usually causes me to enter a crouch state; however, the likelihood that I will notice the glitch has occurred in time to react to a quick mixup is… not very high :frowning:

Some of these things originally felt like execution errors; I thought maybe I was just having a bad few days. When the problem persisted, I decided to try some troubleshooting in the form of replacing the microswitches in my JLF because they felt sort of flimsy–like they had lost some spring.

Initially, this seemed to remedy the problem (though I am now convinced that I was blinded by my ability to actually do the switch replacement successfully). The problem is as bad as it ever was, and the down input is still the only affected input. Every other input, all buttons included, seem to work perfectly every time.

Here is some information on my exact setup:

Parts that may matter:

  1. Sanwa 30mm buttons
  2. madcatz fightpad PCB (self-hacked)
  3. I don’t remember the wire gauge, but it is uniform throughout the stick and is in the 22ish range ( would check the roll, but I ran out recently)
  4. Sanwa JLF-TM (http://www.lizardlick.com/Sanwa-JLF-TM-8T-SK-Joystick_p_258.html). There is no internal PCB, so no wire harness or any of that jazz.

Random information that may matter:

  1. I do NOT use quick connects. Every button and microswitch is directly soldered to the wire.
  2. The stick worked perfectly fine for several months with this exact setup. The problem seemed to appear over night.
  3. I am unable to accurately replicate the backwards walk issue in training mode. It does occur in both local and online play, though, so I can rule out any possible lag issues (though I seriously doubt lag could even cause this).

What I have tried:

  1. Microswitch replacement
  2. Full re-soldering of common ground as well as all things related to the down input
  3. Checked to make sure the PCB’s “stick picking switch” was set to the correct, middle setting

That is about all of the information that I can put forward. I believe that I have covered every base and I apologize again for the long read. Ideally, I would like to get this working without having to replace more parts, but I’m not sure what else I can do to troubleshoot the issue and get it fixed. I would like to try some multimeter readings, but I honestly don’t even know how I would check to see if anything is wrong through such a method.

Thanks for taking the time to read this, hopefully someone will know a miracle cure!


#9

seems like the microswitch that handles the down direction could be at fault… other than replacing the switch or adjusting the leaf spring to be more sensetive (carefully bending the spring to activate down). check your solder… check the pcb… make sure the switch in the back of the fight pad is switch to the middle position indicating its set to DP… if you are looking at the jlf the microswitch that controls the down directional is at 12 o’clock ( just saying it since I get ass backwads at times)… If all is well I would go with replacing that microswitch…


#10

The first thing to check is to make sure the down direction works by itself. Desolder the wires and connect them together directly just to see if down reacts properly. It likely should, since it is working normally, but if something weird is going on elsewhere that causes it to not work immediately, then the problem might lie therein.

And this is the one you just replaced? I only ask because the down direction tends to be the first direction to go, if you think about it, it’s the one most used, quarter circles and DPs will always use down, regardless of the direction or position that you need to use. Also, blocking low, in either direction will wear on the down, though the direction of back tends to alternate, making the down direction tend to be the most used.

Another thing could possibly be the actuator, if it gets ground down, you lose some of the engage distance. It’s only in something I’ve seen in an extreme case, though, and it would probably affect all of your directions.

Also, if the switch is new, perhaps you could check the placement of it and make sure it’s not slightly out of position? I know it’s hard to do with the body and all, but if it’s moved back, or the body isn’t holding it in properly, it could cause an issue.


#11

Indeed, this is the new set of switches (I replaced them all for consistency), and the problem is exactly as it was. They are all brand new and super-springy. I’m going to remove the gate again and see if I can better eliminate any wiggling of the switches, though they seem pretty snug, and I’ll try your first suggestion.

Thanks as always, you two!