LS-32-02 Problem


#1

Okay i just wired up my stick, everything works fine except:

the stick itself doesn’t work, the only thing that works is: up+right which gives me a “down” command on xbox 360. right and up on their own doesn’t do anything.
any tips? the wiring looks fine.


#2

Most likely you hooked up the 5-pin connector wrong. I did the same thing with my HRAP and it behaved the exact same way, flip the connector over and hook it up again it should work just fine.


#3

you cant flip the 5-pin connector, it doesn’t fit the other way.

i tested my wiring completely, i just cant find anything. it works perfectly just until the stick.
pics are coming, one second.


#4

http://i447.photobucket.com/albums/qq192/skongi/SANY0111-1.jpg?t=1237402950

http://i447.photobucket.com/albums/qq192/skongi/SANY0110.jpg?t=1237402950


#5

Last I checked you can flip the wired connector. This happened to me on my SE when I had the connector upside down. EXACTLY as you say is happening to you. I would triple check that if I were you, because the probems are way too similar and a quick flip fixed the issue.


#6

it really doesn’t fit the other way, the “locking tab” is in the way.


#7

Maybe you can switch the wires around on your eurostyle terminal block? I think that the colors on your wiring are off. The colors really depend on how you orient the stick.

It might be that you have the ground connected on the wrong pin.


#8

i just looked at the pcb of the stick again, and after i put the parts of the seimitsu together again - one of the sides worked, but only one.
the one on the south side works now.
wired that one to all the directions, they work. other micro switches don’t do anything.

it really, really can’t be the wiring.


#9

looks like you need to test the microswitches. Also take a your ground wire and contact it to the euro style block to activate the directions if you already haven’t already done so.

If you have, you will need to test the microswitches that seem faulty. If they all work then perhaps your joystick pcb is faulty.

Good luck.


#10

okay i am SUCH an idiot.
the “up” direction was wired to ground, and ground was wired to “up”.
damn i checked everything but forgot about that.

thanks for the help, the switching the pin connector idea made me think about this solution.


#11

hmm weird my ls 32-01 doesnt have a locking tab, eh w/e


#12

That explains why only up worked. Hope something I wrote helped.


#13

For testing the pcb I connect the pad to the USB port of the PC and check the properties of the gamecontroller. Then I’m connecting one by one all signal lines to ground and check the activation of the buttons/ directions in properties window. Due to this you minimize the problem space.

Then the wiring between the arcade parts can easily checked with a multimeter.