Mad Catz stick not working for older (DirectInput) games on PC?


#1

Hey guys, I’m running into a strange issue with my arcade stick and I thought maybe somebody here has seen it. I’m using a Mad Catz Soul Calibur V Xbox360 stick with my PC. For everything that uses XInput (most newer games), it works perfectly. However, when I try to run an older game with joystick support (DirectInput), it doesn’t work, while my old Logitech RumblePad2 does. (Examples tried: Gundemonium, Hydorah, Spelunky.) I tried restarting, unplugging/replugging, unplugging my Logitech gamepad – nothing seems to work.

Strangely, MAME works perfectly as well, even though it doesn’t use XInput. I’ve heard it uses raw input? Not sure what that is, but it seems to be different from all the other old games I’ve tried.

Any suggestions? Thank you!


#2

I should note that people have reported their normal 360 pads working with some of the above games correctly, and that Microsoft says that their Xbox controllers should be able to work both in XInput and DirectInput mode on PC. It shows up in Microsoft’s game device window and also in the “Input” section of dxdiag.


#3

Okay, I think I solved the puzzle. Just as a diagnostic, I tried to use my arcade stick in an emulator and it worked – but it said joystick 2 instead of 1. This made me realize that maybe the old games that I was trying were only listening to joystick 1. Since I tried unplugging my RumblePad already, I went to dxdiag again and noticed that even though I only had the arcade stick plugged in, it was listed as Controller 1, not 0. So I did a Google search and found this Yahoo! answer, which solved the Controller ID problem. And now I’m getting input in Spelunky, woohoo!

Unfortunately, the input is configured improperly (stick seems to be stuck on upper left corner), but I believe that’s a separate issue altogether. One step at a time…

EDIT: But I’m STILL not getting anything from Gundemonium or Crimzon Clover. It appears that the “fix” I discovered only works for GameMaker games. Sigh.


#4

Most PC games look for directions from an X/Y axis, which the 360 version wont show. MAME will work properly with X/Y axis or POV hats just fine. The common software solution is to use joy2key or a similar program to map everything to keyboard inputs. You could also use hardware mods like a Kitty to dual mod your stick, and it works way better on PC for the non-Xinput stuff.


#5

Well, the strange thing is, none of the buttons work either. If it’s just a POV-hat issue, then shouldn’t at least the buttons be working fine? Shouldn’t it start working when I switch the control pad selection switch to LS or RS? And why would GameMaker games be stuck with the directions in the upper-left corner?

And yeah, I think I’ll have to settle with j2k, though I’ve been planning to get a Kitty anyway – maybe now’s the perfect time to do it! Still, it concerns me that the joystick behaves this way. I just want to make absolutely sure that there’s nothing physically wrong with it. I just don’t understand what could cause this behavior.


#6

If the buttons dont work as well, my bad I missed that. It’d have to be a different problem than the XY axis problem, and I dont know why that would be the case. You may have some luck if you could post up some of the games that are giving you problems so you could at least find out if they work for others with that stick.


#7

Crimzon Clover and Gundemonium Recollection Demo don’t work with the stick at all. (They do with my RumblePad.) Spelunky and Hydorah (GameMaker games) didn’t work at first, but as I mentioned above, I got the buttons to work but the stick is wonky. (Again, both games work out of the box with my RumblePad.) And I tried using the stick with Dustforce, and it didn’t work there either.

Strangely, some programs detect it just fine. As I said, VisualBoy Advance, MAME, joy2key, and others deal with it perfectly. x360ce confirms that all the controls are working, as does the Windows gamepad panel. And dxdiag shows it as a working DirectInput device. WTF?

(And again, the games with Xinput that I’ve tried are totally fine. It’s just these pesky older games.)

EDIT: I just tried the stick on 3 different Windows machines and all had the same results. So it’s not my computer, unless this problem is specific to Windows 7 64-bit.


#8

I can honestly say I don’t have any problems like this with my stick in 360 mode.

I have a round 1 TE.


#9

Open up your device properties for your game controllers, with your stick plugged into your PC
Right click and open Game Controller settings and click on the controller in question.

You should get the properties Window up.

Check there to see if all your buttons and stick controls respond.

Keep in mind for Xbox 360 sticks, you can’t see the Left and Right Analog or the Home/Guide button info, this is normal for many Xbox 360 PCBs on a Windows PC.

Many PS3 PCBs which are PC compatible especially Toodle’s products do not have this issue.

The Idea here is to eliminate that there any issues on the controller hardware side and make sure its a software issue.


#10

Yeah, I see the exact window on the right. All the buttons and the stick work fine.


#11

I just used those images because its whats I have on hand with out making new screen shots.

Well thats good we eliminated the hardware issues. Older DirectInput games can be quirky, If keyboard input works fine use a program like joy to key to map your joystick and buttons to keyboard input. And set your games to keyboard input.


#12

Yeah, I’ll just do that, at least until I get a Kitty. Still, this seems so strange to me. I’ve never seen this level of quirkiness before…

If somebody with the same stick as me (Mad Catz Soul Calibur V FightStick Soul Edition) could try running a few of the games I listed (Crimzon Clover, Gundemonium Recollection Demo, Spelunky) in Xbox360 mode, I would be super grateful. I just really want to make sure that my stick isn’t a special snowflake in this regard.

EDIT: Tried it in Virtual XP mode. Same thing: shows up in game controllers, doesn’t work with the games listed.


#13

Is the stick stuck on RS?
Also, like toodles said, try with joy2key or xpadder.
Sometimes that happens to me when I play sfxt


#14

Nope – switch works correctly, at least in Xinput mode. As for DirectInput mode, as you can see in the screenshots above, it only has one stick, so flipping the switch only serves to disable the stick.